UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #9  -  Geoscape is rather slow
Posted Jan 30, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     hoehrer
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 9 imported from sourceforge.net tracker on 2013-01-28 18:08:35

Ok, i'm not quite sure if this is a bug or a feature request, so i'm putting it here. Feel free to move it to the correct place...

The earth-map screen (geoscape) behaves rather sluggish
 (i.e the mouse reacts/moves very slow)[1] , but the
rest of the game (except the 3D view which I can't verify since maps do not load for me... might be a real bug) is displayed very fast. Also i've played the TD1 very fluently (3D as well), so I don't think it's a 'power' question.

Is there a chance that the geoscape will be made faster in the future? Or can anybody get me some tips/hints how the map is drawn so i can search if i find a faster way?

Werner

1 Which is most probably because of my slow system 650MHz, 512MB RAM, TNT2 32MB
Comments Ported from Sourceforge  ⇑ top
tlh2000 (2006-02-22 08:02:29)  ⇑ top
Logged In: YES user_id=116930

do you try set to set the gl_maxtexres to a lower value? possible values are 256, 512, 1024 and 2048
hoehrer (2006-02-22 19:30:27)  ⇑ top
Logged In: YES user_id=1434318

Ok, i've set the value in the config.cfg as following ...

set gl_maxtexres "1024"

... and it works for me now :D .. marking this 'bug' as such.

Many thanks, Werner
Steps to reproduce this issue
Nothing entered.