UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #5655  -  Switching reaction fire mode doesn't work
Posted Apr 07, 2017 - updated Apr 19, 2017
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     DarkRain
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     anonymissimus
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    1 week, 1 day, 5 hours
  • Category
    User interface
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
master@02acf724e9e9f25b7697ef7d8d0a90f063bbbba5

Klicking onto the strange something in the bottom left corner of the fire mode selection menu should activate that fire mode for reaction fire, but only the bottom most mode can be used it seems, independently from whether reaction fire is active for that actor.

attached: screenshot and log

In the log there are some lua errors. They happened during the alien turn, right after my soldier (whose reaction fire mode I couldn't change) reaction-fire killed that sheevar.
Steps to reproduce this issue
Nothing entered.