UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #5273  -  equipment definition fails
Posted Feb 03, 2014 - updated Feb 06, 2014
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     DarkRain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     shipit
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Always
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Trivial
  • Platform
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png x86
Issue description
According to equipment_missions.ufo aliens in the early stage should get a plasma pistol (fully loaded) 100%, an additional ammo 100% and also a Kerrblade 100% in this case :

equipment alien_workers1
{
mininterest 0
maxinterest 79

// Secondary
item (plaspistol 100)
item (plaspistol_ammo 1)

// Misc
item (kerrblade 100)
}


Imo this should work, because there is enough space for all those items within the inventory and its weight does not exceed the max.

But it does not work. Aliens never get a Kerrblade in this case for some reason, making the equipment system really erratic.

Steps to reproduce this issue
Nothing entered.