UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #3448  -  missing footstep sounds
Posted Dec 27, 2012 - updated Mar 31, 2013
shipit (shipit) has been working on this issue since January 28, 2013 (20:48)
Issue details
  • Type of issue
    Bug report
  • Status
     
    Open
  • Assigned to
     shipit
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     aduke1
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    1. Very low
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 3448 imported from sourceforge.net tracker on 2013-01-28 20:10:24

In the attachment you'll find a list of textures detected by the new cunit.

Note that this is just a small example. The test currently only checks a small 6x6x2 area around the center of the map. Also note that the result is kinda random because the test checks only one seed per assembly. That is, some tiles may not be included in the test, especially ufo tiles.
Comments Ported from Sourceforge  ⇑ top
aduke1 (2012-12-28 13:47:33.593000)  ⇑ top
ShipIt, the test is now in place at the buildbot.

A full test takes too long to be run every time testall is run. So it's set up almost like a game: After 5 maps (the first of them is fully checked) with missing sounds, the test stops. If we manage to 'clean' one of those 5 maps, the next map will show up in the next run.

Have fun ;)
shipit (2012-12-29 16:22:01.737000)  ⇑ top
It seems to test the first twenty assemblies only. So now I get "perfect" twenty times, but nothing more.
aduke1 (2012-12-29 23:57:41.286000)  ⇑ top
It does. On purpose. Keep in mind that the results are random (RMA), so check more than one log. Btw I hadn't thought that you would fix the long list that fast smileys/2.png

Increased: const int skipCount = 6; // to skip the first n mapDefs const int mapCountMax = 30; // should of cause be higher than skip + bad

Also, now the first *two* maps are fully tested.
shipit (2012-12-30 10:12:49.383000)  ⇑ top
One note : This only makes sense if the buildbot runs the test and writes the found textures continuous in a texture_misses_sound.txt file.

And it would be good if we could entirely skip the /common/*.* textures.
aduke1 (2012-12-30 13:41:04.664000)  ⇑ top
I understand you'd rather have them all in one file. So I ran the small test for all maps and attached the result.
aduke1 (2012-12-30 16:26:36.540000)  ⇑ top
Next run is attached
shipit (2012-12-30 16:38:31.970000)  ⇑ top
Thanks.

I tried after your last changes. Source updated and rebuilt.

testall --only-MapDefTests --log

No matter how often I run it, it´s always testing the same 24 assemblies.

Only difference - instead of "perfect" for twenty times I now get twenty four times "Nothing detected". smileys/2.png
aduke1 (2013-01-04 01:13:10.512000)  ⇑ top
here are a feNExt time I'll have to run a bigger testarea.
aduke1 (2013-01-06 01:07:26.738000)  ⇑ top
This is from a test with a 20x20 area around the center.
aduke1 (2013-01-06 01:09:07.140000)  ⇑ top
I've also created a little batchfile for you if you want to run the tests yourself.
Steps to reproduce this issue
Nothing entered.