UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #324  -  Dropping non armor on person causes assert errors
Posted Sep 11, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     wilminator
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Campaign
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 324 imported from sourceforge.net tracker on 2013-01-28 18:18:28

Dropping any non-armor item on a solider (or just outside any inventory container) causes 3 assert errors. Actual error windows attached and read as follows:

Error 1: Assertion Failed! Program: C:\Program Files\UFOAI-2.O-RC4\ufo.exe File: game/q_shared.c Line: 2385 Expression: !Q_strcmp(CSI->odscacheItem.t.type, "armor")

Error 2: Assertion Failed! Program: C:\Program Files\UFOAI-2.O-RC4\ufo.exe File: game/q_shared.c Line: 2917 Expression: !Q_strcmp(CSI->odschr->inv->c[CSI->idArmor-
item.t].type, "armor")


Error 3: Assertion Failed! Program: C:\Program Files\UFOAI-2.O-RC4\ufo.exe File: game/q_shared.c Line: 2946 Expression: !Q_strcmp(CSI->odschr->inv->c[CSI->idArmor-
item.t].type, "armor")


Since I cant find any code in the source that checks to see what kind of equipment is placed anywhere in either client/cl_menu.c or game/q_shared.c, I'm guessing that idArmor is set for non-armors, too?

mwilmes@wilminator.com wilminator@sf.net

Comments Ported from Sourceforge  ⇑ top
wilminator (2006-09-11 06:19:35)  ⇑ top
Zipped error images
cassiterite (2006-09-11 10:24:25)  ⇑ top
Logged In: YES user_id=1171370

This issue was recently brought to our attention by: http://sourceforge.net/tracker/index.php?func=detail&aid=1555349&group_id=157793&atid=805242

It has recently been fixed in the SVN version of the game (soon to be release RC5 hopefully).

Thanks for finding and reporting bug issue nevertheless.
Steps to reproduce this issue
Nothing entered.