UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #3059 Reaction fire default setting ON
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Description
[http://sourceforge.net/p/ufoai/bugs/3059 Item 3059] imported from sourceforge.net tracker on 2013-01-28 19:58:38 Trying to check if reaction fire implementation matches specification as mentioned in 2.4 TODO: http://ufoai.ninex.info/wiki/index.php/TODO/2.4 Specification says reaction fire should be ON by default, but current implementation has it OFF by default. ===== Comments Ported from Sourceforge ===== ====== tlh2000 (2011-10-21 17:54:09) ====== it depends - in campaign mode it should have the setting of the last fight - see GAME_CP_InitializeBattlescape ====== natewr (2011-10-21 23:45:08) ====== Ok, but default at beginning of campaign was OFF, not ON. ====== tlh2000 (2011-10-22 14:46:46) ====== CL_GenerateCharacter should set the state then ====== aduke1 (2011-11-28 21:16:54) ====== The priority was adjusted according to the "bug priority rules". See http://ufoai.ninex.info/wiki/index.php/Bugs#Bug_Priorities ====== aduke1 (2012-03-03 23:24:53) ====== CL_GenerateCharacter is not the right place, because we need a weapon equipped in order to set RF to ON. ====== aduke1 (2012-10-04 23:01:43.612000) ====== - **assigned_to**: Duke - **milestone**: --> 2.4
Steps to reproduce this issue
Nothing entered.
Comments (2)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    General
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    2. Low
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
  • Time spent
    107 weeks, 0.24 hours
    Click here to see time logged against this issue
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)