UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report #2903 Sniper rifle fires double shots
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
crystan (crystan) has been working on this issue since January 28, 2013 (20:47)
Description
[http://sourceforge.net/p/ufoai/bugs/2903 Item 2903] imported from sourceforge.net tracker on 2013-01-28 19:54:51 Sometimes, sniper rifle fires two projectiles in a single shot. It's not just visuals, there are 2 bullets -- i've seen one of them hitting the wall and other -- the alien somewhere about 10 squares from the first hit. Screenshot attached. ===== Comments Ported from Sourceforge ===== ====== alextishin (2011-06-11 14:55:54) ====== Two sniper rifle bullets flying in parallel ====== edirr (2011-06-14 09:56:48) ====== The bug seems to be visual in nature. I have seen this happen many times, but it never uses more than that one shot of ammo. The same bug can also happen with the Electromagnetic Rifle. ====== pachilds (2011-08-31 04:34:26) ====== I can also confirm this. Hardware that I am using nvidia GT220 card with proprietary nvidia driver under ubuntu 11.04 (i386) version 2.4-dev ====== aduke1 (2012-10-04 20:26:21.836000) ====== - **assigned_to**: Martin Gerhardy ====== darkrainx (2012-10-24 03:29:18.219000) ====== Also in the Electromagnetic Rifle: [#3199] ====== tlh2000 (2012-12-14 07:58:18.722000) ====== is this still the case? ====== natewr (2012-12-14 11:39:24.281000) ====== I've never noticed it, but never tried to replicate it. I'll try and load up a skirmish and shoot lots of sniper rifles and see if I can tell. ====== natewr (2013-01-17 10:14:35.932000) ====== I can confirm this happens. But I've looked in the weapon definitions and can't see any reason for this. There is no delaybetweenshots, which can cause multiple shots to appear on a single-shot weapon. I looked at the particles and nothing jumped out at me, but that might be the source of the problem, so I'll assign this to Crystan.
Steps to reproduce this issue
Nothing entered.
Comments (0)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Battlescape
  • Targetted for
    Not determined
  • Status
    Open
  • Priority
    3. Normal
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)