UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #2896  -  Rotating multiple selections at once bugged in UFORadiant
Posted Jun 04, 2011 - updated Jan 28, 2013
mattn (tlh2000) has been working on this issue since January 28, 2013 (20:47)
Issue details
  • Type of issue
    Bug report
  • Status
     
    Open
  • Assigned to
     mattn
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     mcr2010
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Map Editor (UFORadiant)
  • Resolution
    Not determined
  • Priority
    5. Important
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 2896 imported from sourceforge.net tracker on 2013-01-28 19:50:51

Selecting and rotating multiple selections (such as model+lightclips+weaponclips) can lead to a strange result:

Some of the brushes get rotated, others don't.

Comments Ported from Sourceforge  ⇑ top
tlh2000 (2011-06-05 06:43:25)  ⇑ top
keep in mind that when you select multiple things, the origin is not the same as when select only one thing.
tlh2000 (2012-06-11 11:48:26)  ⇑ top
revisions at 2009-04-01 00:00 are already broken.
tlh2000 (2012-06-11 11:50:48)  ⇑ top
this is also broken in netradiant - so i suppose it's an ancient gtkradiant 1.5 bug
tlh2000 (2012-06-11 11:53:50)  ⇑ top
increased the prio because the mappers need this feature to create crashed-ufo missions
Steps to reproduce this issue
Nothing entered.