UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #2893  -  Brushes seem to be changed sometimes in the bsp
Posted Jun 04, 2011 - updated Jan 28, 2013
mattn (tlh2000) has been working on this issue since January 28, 2013 (20:47)
Issue details
  • Type of issue
    Bug report
  • Status
     
    Open
  • Assigned to
     mattn
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     mcr2010
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Map Compiler (ufo2map)
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 2893 imported from sourceforge.net tracker on 2013-01-28 19:50:51

An example would be the bench with 4 seats on the ground floor near the main entrance of laboratory map. Everything is correct in the editor, but then the brush of one of the armrests gets somehow manipulated during compilation and is displayed wrong in-game. I tried to fix it by deleting the armrest and copying a good one, still the error does not disappear.
Comments Ported from Sourceforge  ⇑ top
tlh2000 (2011-06-05 14:07:01)  ⇑ top
this is a floating point issue - alive since quake2 and maybe earlier. please try to work around it by redoing the brushes. this bug will most probably never get fixed
tlh2000 (2011-06-13 06:49:06)  ⇑ top
http://zerowing.idsoftware.com/pipermail/gtkradiant/2010-December/011475.html
Steps to reproduce this issue
Nothing entered.