UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #26  -  no mouse cursor in windowed mode
Posted Mar 06, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     mattn
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     fatboy666
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 26 imported from sourceforge.net tracker on 2013-01-28 18:08:35

Hi, please fix this bug.

I don't know, if this is a known bug: I started UFO:AI in windowed mode yesterday. As a result I didn't have a mouse cursor any more and I was stuck to the main menu. I had to kill ufo from a terminal.

Maybe a non-mouse-grabbing mode would be fine, too.
Comments Ported from Sourceforge  ⇑ top
fatboy666 (2006-03-06 15:09:50)  ⇑ top
Logged In: YES user_id=545475

Maybe it's related to ( https://sourceforge.net/tracker/index.php?func=detail&aid=1414788&group_id=157793&atid=805242 )
fatboy666 (2006-03-06 15:28:16)  ⇑ top
Logged In: YES user_id=545475

Hello again.

With 'vid_grabmouse' set to '0' the windowed mode works, but the mouse leaves the window 'too early', that means there are about 100 pixels left to the right and to the bottom side. The cursor leaves the window on left and upper side is as supposed to.

I've attached a screenshot to demonstrate the problem.
fatboy666 (2006-03-06 15:28:19)  ⇑ top
screenshot of the 'bug'
tlh2000 (2006-04-18 17:56:18)  ⇑ top
Logged In: YES user_id=116930

which renderer? is this still in actual rev?
Steps to reproduce this issue
Nothing entered.