UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Open Bug report #1956 Texture rotation issue
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
shipit (shipit) has been working on this issue since March 10, 2013 (21:55)
Description
[http://sourceforge.net/p/ufoai/bugs/1956 Item 1956] imported from sourceforge.net tracker on 2013-01-28 19:14:56 I've found a case where the rotation of a texture is different between the editor and the game. Refer to the attached screenshots. The map in question is base/maps/shelter/shelter_corridor_ne.map ===== Comments Ported from Sourceforge ===== ====== btaxis (2008-12-24 15:54:02) ====== Texture as shown in radiant ====== btaxis (2008-12-24 15:54:24) ====== File Added: game.jpg ====== btaxis (2008-12-29 12:47:47) ====== ====== btaxis (2008-12-29 12:47:48) ====== I've attached a test case. There are two brushes in this test map. Both appear normal in the editor, but one appears rotated ingame. The bsp was compiled with: ufo2map.exe -extra base\maps\test_texture.map Note that I encounter an assert if I remove one of the brushes. The assert is cmodel.c:831 minY <= maxY. File Added: test_texture.zip ====== richlv (2008-12-29 13:37:47) ====== linux x86, trunk rev 21312 loading the attached bsp shows that one texture is rotated incorrectly. compiling the attached testcase .map, and loading that bsp shows both textures ok. ====== richlv (2008-12-29 13:46:06) ====== oh, maybe we can get blondandy to look at this one ;) ====== blondandy (2008-12-29 21:44:18) ====== I am pretty sure the answer to this will take me a long time, the answer will probably lurk in some code that I don't know. I am short of time, ATM. I won't be offended if someone else wants to have a look at this. ====== sf-robot (2010-01-27 02:20:32) ====== This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker). ====== btaxis (2010-01-27 08:55:45) ====== Bug is still alive, reopening. ====== aduke1 (2012-09-30 23:55:01.264000) ====== - **milestone**: 2.3 --> 2.3.x
Steps to reproduce this issue
Nothing entered.
Comments (0)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Map Compiler (ufo2map)
  • Targetted for
    Not determined
  • Status
    Open
  • Priority
    3. Normal
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)