UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #1956  -  Texture rotation issue
Posted Dec 24, 2008 - updated Mar 10, 2013
shipit (shipit) has been working on this issue since March 10, 2013 (21:55)
Issue details
  • Type of issue
    Bug report
  • Status
     
    Open
  • Assigned to
     shipit
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     btaxis
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Map Compiler (ufo2map)
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 1956 imported from sourceforge.net tracker on 2013-01-28 19:14:56

I've found a case where the rotation of a texture is different between the editor and the game. Refer to the attached screenshots.

The map in question is base/maps/shelter/shelter_corridor_ne.map
Comments Ported from Sourceforge  ⇑ top
btaxis (2008-12-24 15:54:02)  ⇑ top
Texture as shown in radiant
btaxis (2008-12-24 15:54:24)  ⇑ top
File Added: game.jpg
btaxis (2008-12-29 12:47:47)  ⇑ top
 
btaxis (2008-12-29 12:47:48)  ⇑ top
I&#039;ve attached a test case. There are two brushes in this test map. Both appear normal in the editor, but one appears rotated ingame. The bsp was compiled with: ufo2map.exe -extra base\maps\test_texture.map Note that I encounter an assert if I remove one of the brushes. The assert is cmodel.c:831 minY <= maxY. File Added: test_texture.zip
richlv (2008-12-29 13:37:47)  ⇑ top
linux x86, trunk rev 21312 loading the attached bsp shows that one texture is rotated incorrectly. compiling the attached testcase .map, and loading that bsp shows both textures ok.
richlv (2008-12-29 13:46:06)  ⇑ top
oh, maybe we can get blondandy to look at this one ;)
blondandy (2008-12-29 21:44:18)  ⇑ top
I am pretty sure the answer to this will take me a long time, the answer will probably lurk in some code that I don&#039;t know. I am short of time, ATM. I won&#039;t be offended if someone else wants to have a look at this.
sf-robot (2010-01-27 02:20:32)  ⇑ top
This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).
btaxis (2010-01-27 08:55:45)  ⇑ top
Bug is still alive, reopening.
aduke1 (2012-09-30 23:55:01.264000)  ⇑ top
- **milestone**: 2.3 --> 2.3.x

Steps to reproduce this issue
Nothing entered.