UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #5554 [transfer] Transfers prevented because of craft transfer allowed when hangar not completed yet
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Description
This is two bugs in one: - Somehow, I managed twice to transfer aircrafts between a production base and a destination base, with room for them (if I remember well, based on screenshots), but the Transfer screen tells that there's a capacity overload. In both cases, a hangar was under construction, perhaps quite near completion). - The transfer system being so fooled, prevents any other transfer to this destination base, whereas the base's stores are not full. This means that while the scheduled craft has not arrived, transferring an ammo clip is not possible! (The same thing occurs when the Alien Containment Unit is overloaded, btw). ==== Expected behavior (or not?): ==== # If no free hangar, no craft can be bought nor transfered to the base. # If a craft is being transfered (transiting to new base), it's listed in the base's craft roster, and considered as occupying its future hangar. # Should the hangar be canceled or destroyed, the assigned craft should be either lost, or proposed to be sold or transfered to a new base. At once. If the assigned craft is still transiting, then something should be done (but it's not the topic here): e.g. the same Sell/Transfer choice could be proposed when it arrives. # Should a base be overloaded as far as a transfer category is concerned (here: craft): the game pauses until the problem is handled (isn't this currently the case with the "aliens" category?). ==== Current behavior: ==== # This works as expected. What now if a hangar is under construction at destination base? # The transfered craft is listed in the base's craft roster, and its hangar is counted as occupied in the Buy/Sell screen (e.g. 0/3 free). But does another hangar under construction interfere with the base capacity computation, or what does mean the e.g. -1/3 free in the Transfer screen mean (same situation)? # I don't know. # The game goes on. Any transfer from any base to the destination base is prevented. Perhaps, the (-1/3) display is only a way to tells that a fourth hangar is under construction, and that the base's capacity will be soon (1/4). In this case, the transfer system shouldn't detect a base capacity overload. In case this might be the same for any base container, such as employees and Quarters, or items and Stores, a check could be worth here.
Steps to reproduce this issue
I don't know. Perhaps, having a hangar under construction (and near completion) is a trigger. Then, somehow: # Transfer a craft from production base to destination base while a hangar is still under construction. # Try and transfer anything else while transfer hasn't arrived or the new hangar isn't completed.
Comments (6)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (6)
  • /bugs/files/show/499
    ufoaiTransferBug1.jpg uploaded Nov 08, 2015 by unknown user
  • /bugs/files/show/500
    ufoaiTransferBug2.jpg uploaded Nov 08, 2015 by unknown user
  • /bugs/files/show/501
    ufoaiTransferBug3.jpg uploaded Nov 08, 2015 by unknown user
  • /bugs/files/show/502
    ufoaiTransferBug4.jpg uploaded Nov 08, 2015 by unknown user
  • /bugs/files/show/503
    ufoaiTransferBug5.jpg uploaded Nov 08, 2015 by unknown user
  • icon_download.png transferBug.savx
    transferBug.savx uploaded Nov 08, 2015 by unknown user
Duplicate issues (0)