UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #5534 [Geoscape] Non researched UFOs may be identified through the Transfer notifications
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Description
When a new UFO is detected, the Geoscape overlay (Detection notification) just displays "UFO#", as well as the Recovery notification (with a blue icon) Presumably, the UFO's name is #2294 "UFO", and the Recovery notification is #2753 "Recovered %s from the battlefield. UFO is being transported to %s". I'm not sure if this the same if you decide to sell the UFO; it should be #2756 "Recovered %s from the battlefield. UFO sold to nation %s, gained %i credits." However, if you choose to transfer this new UFO to a yard (or from a yard to another), the Transport/Transfer notification (with a black icon) tells you its name! Indeed, you get the #2745 "%s was transfered to %s" (e.g. "UFO - Gunboat was transfered to UFOYard01") On this occasion, it looks like no test is done and hence, that #2294 "UFO" is never used as a name. The true names are always used. They can be found between #62 and #80. '''Note:''' On the first time you transport an unknown UFO to a yard, you get its name through the research proposal, anyways. I don't know if this should be corrected. What I question here, is the fact that even if you postpone the research for month, you keep having anonymous Detect and Recovery notifications, while the Transfer notifications keep telling the real names. Quite illogical, isn't it? '''Suggestion:''' Add a test (?) and use #2294 instead of the #62-#80 real names as long as the UFO is not researched. Of course, you know its name through the UFOpaedia entry and the research proposal, but it's only one line in the notification log.
Steps to reproduce this issue
# Postpone an UFO research or wait for a new type to be captured. # Transfer the recovered UFO to a yard. # Wait for the transport to be done. # Review all the notifications in between (recovery, transfer initiated, transfer arrived)
Comments (4)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (3)
  • /bugs/files/show/476
    ufoGeoscapeUfoUnknown1.jpg uploaded Oct 29, 2015 by unknown user
  • /bugs/files/show/477
    ufoGeoscapeUfoUnknown3.jpg uploaded Oct 29, 2015 by unknown user
  • /bugs/files/show/478
    ufoGeoscapeUfoUnknown2.jpg uploaded Oct 29, 2015 by unknown user
Duplicate issues (0)