UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #5529  -  [UFOpaedia] Herakles Transporter's cargo pod is displayed back to front
Posted Oct 26, 2015 - updated Oct 28, 2015
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     DarkRain
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     rodmar
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    1 day, 15 hours
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
The Heracles Transporter's cargo pod (which model is used alone on most ground missions battlescape) seems to be ill-attached to the Transporter craft. Its front side (identified by what looks like a windscreen) is displayed on the transporter's backside, and its backside (the pod's door) is displayed on the transporter's frontside, under the transporter's cockpit.

This had always questioned me, as far as aerodynamics laws are concerned. Now, what revealed the bug is that on some missions, the transporter craft's model is used on the battlescape on top of the cargo pod's model. This time, I could took a screenshot for proof of the discrepancy.

Suggestion: Correct the craft+cargo pod model in the UFOpaedia (and Craft management screen).
Steps to reproduce this issue
Go to UFOpaedia, Heracles entry (when searched) OR Go to the Base Craft page and select a Heracles (if assigned to the base)