UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #4990 Laser battery facility can not be built in-base
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "NOT AN ISSUE".
Description
Following up on [[http://ufoai.org/forum/index.php/topic,7321.0.html|this report]], I was unable to find any way to build the base building building_laser, even after researching rs_laser. This might be just a scripting problem, but I've had a look and the requirements seem correct. In my mind, here is what I think should happen: 1. Player researches Continuous Wave Laser Operation (rs_laser), opening up research on base laser turrets (rs_baselaser). 2. Player completes research of rs_baselaser, which should automatically lead to completion of rs_building_laser. The player should now be able to build a laser turret facility (building_laser) and produce a base laser turret (rs_baselaser) to install in that facility. However, I found that upon researching rs_laser and rs_baselaser, I was unable to build a laser turret facility. I could produce a base laser turret, but I could not install it into a facility. Somehow, rs_building_laser is not getting unlocked properly. An alternative solution would be to do away with the laser battery altogether. The missile battery could instead be an aerial defense battery installation that can take missile and laser mounts (and any other mounts we might create in the future). ''I set the priority high on this because it is one of the very first research victories in the game, so it should work flawlessly so players can gain confidence in the game early.''
Steps to reproduce this issue
Nothing entered.
Comments (1)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Campaign
  • Targetted for
    2.5
  • Status
    Closed
  • Progress
  • Priority
    6. Vital
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    NOT AN ISSUE
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Trivial
  • Platform
    Not determined
  • Architecture
    x86
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)