UFO: Alien Invasion Issue Tracker
UFO: Alien Invasion
Go to the previous open issue
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
icon_project.png UFO: Alien Invasion / Closed Bug report #4955 base defence mission fails
Go to the next issue (open or closed)
Go to the next open issue
This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    6. Vital
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
  • Time spent
    1 week, 1 day, 200 hours
    Click here to see time logged against this issue
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Always
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (1)
Description
The base defence mission fails due to commit
7f8a714d src/server/sv_ccmds.cpp, committed on April 1st ;)

lines follow:
164 char bufMap[MAX_QPATH];
165 char bufAssembly[MAX_QPATH] = "";

Thanks!!
Steps to reproduce this issue
Oh, it actually cuts off the map string after 63 characters. It only affected my base defence mission, but I know it'll have a crazy effect on any mapstring over 63 chars. I used bisect to zero in on the change that broke it. I set bufMap and bufAssembly to 1024 char length, and that worked.
Todos (0 / 0)
Issue created
footer_logo.png The Bug Genie 4.3.1 | Support | Feedback spinning_16.gif