UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #4906 Disabling reaction fire when weapon actions open does not refresh available actions
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Description
v2.5-dev-win 2013-Mar-01 If you have a weapon actions menu (select what type of shot/action you want to perform with that weapon), it takes into account how many time units you have left minus any reserved time units. Any actions for which insufficient time units remain are disabled on the menu. However, if you disable reaction fire with keyboard shortcut ("x"), the weapon action menu does not update until you close and reopen it.
Steps to reproduce this issue
In the attached 3 screenshots: # My soldier has 24 TU left, with 8 reserved, and a medkit action menu open. Since 20 TU are required for any action, all three options are disabled. # Disabling reaction fire with keyboard shortcut "x" now leaves 24 TU available, and all actions should be available. The medkit menu icon (crosshairs) changes from grey to blue indicating actions are now available, but the already-displayed action menu is not refreshed to allow me to actually use any of the now-available options. # Closing and re-opening the action menu now correctly shows the available actions.
Comments (4)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    User interface
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    4. Useful
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (3)
  • /bugs/files/show/38
    reaction fire disabled actions 01.jpg uploaded Mar 04, 2013 by unknown user
  • /bugs/files/show/39
    reaction fire disabled actions 02.jpg uploaded Mar 04, 2013 by unknown user
  • /bugs/files/show/40
    reaction fire disabled actions 03.jpg uploaded Mar 04, 2013 by unknown user
Duplicate issues (0)