UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #4898 Reaction Fire and Stand Up/Down Crouch button don't update between soldiers on battlescape
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Description
v2.5-dev-win 2013-Mar-01 Switching between soldiers in battlescape (e.g. with ) does not update the Reaction Fire and Stand Up/Down icons, the icons just stay at whatever state they currently are no matter the value for the currently-selected soldier. The buttons still work to toggle the state of the current soldier, and do update when clicked, but the graphic does not update when selecting a new soldier.
Steps to reproduce this issue
==== An illustrated walkthrough ==== === Reaction Fire === # Starts as expected, reaction fire is disabled and icon shows that: [[Image:http://imageshack.us/photo/my-images/23/ufo02.jpg/|ufo02.jpg]] # Toggle reaction fire button and reaction fire icon shows correctly, also reserved-time bar shows correctly. [[Image:http://imageshack.us/photo/my-images/46/ufo03y.jpg/|ufo03y.jpg]] # Switch to next soldier and reaction fire icon "sticks" at previous state. This soldier does not have reaction fire enabled, but icon shows it as enabled. [[Image:http://imageshack.us/photo/my-images/836/ufo05.jpg/|ufo05.jpg]] # Click reaction fire button and reaction fire is enabled. Presumably the reaction-fire button is set to "enabled" graphic at this point, but since it was already showing that no change is visible. [[Image:http://imageshack.us/photo/my-images/145/ufo06.jpg/|ufo06.jpg]] # Click reaction fire button again and reaction fire is correctly disabled and button graphic is also correctly updated to disabled. [[Image:http://imageshack.us/photo/my-images/580/ufo07.jpg/|ufo07.jpg]] === Stand Up / Stand Down === # Starts as expected, soldier is standing and stand-up/down button graphic is correct: [[Image:http://imageshack.us/photo/my-images/577/ufo08.jpg/|ufo08.jpg]] # Tell soldier to crouch, all works as expected (soldier crouches, button graphic shows crouched): [[Image:http://imageshack.us/photo/my-images/407/ufo09.jpg/|ufo09.jpg]] # Switch to next soldier, but crouch button graphic shows already crouched even though soldier is standing: [[Image:http://imageshack.us/photo/my-images/832/ufo10.jpg/|ufo10.jpg]] # Tell soldier to crouch and they do, button graphic is presumably updated but since already shows soldier as crouching no visible change: [[Image:http://imageshack.us/photo/my-images/838/ufo11.jpg/|ufo11.jpg]] # Tell soldier to stand and they do, button graphic is correctly updated.
Comments (3)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Battlescape
  • Targetted for
    2.5
  • Status
    Closed
  • Progress
  • Priority
    7. Critical
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
  • Time spent
    1 day, 0.21 hours
    Click here to see time logged against this issue
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)