UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #4885 ufo2map goes to infinite loop with maps/shelter/shelter_room_e_b.map[2b0372858a407d4c1dfaba4f5e9d68cad4e5882b]
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Description
I get freeze at compiling new shelter_room_e_b.map: Thread 1 (Thread 0x7fffefbd37c0 (LWP 27256)): #0 0x000000000040b174 in BuildLights () at src/tools/ufo2map/lightmap.cpp:310 #1 0x00000000004054b8 in LightWorld () at src/tools/ufo2map/lighting.cpp:52 #2 0x0000000000403bff in main (argc=, argv=0x7fffffffd868) at src/tools/ufo2map/ufo2map.cpp:696 (gdb) f 0 #0 0x000000000040b174 in BuildLights () at src/tools/ufo2map/lightmap.cpp:310 310 if (VectorEmpty(p->light)) (gdb) p *p $2 = {face = 0x2f307ac , winding = 0x617eae0, origin = {4, 168.585785, 11.4142132}, normal = {-0, -0.707106829, 0.707106829}, area = 135.764496, light = {0, 0, 0}, next = 0x0} (gdb) l 308 const patch_t *p = face_patches[i]; 309 while (p) { /* iterate subdivided patches */ 310 if (VectorEmpty(p->light)) 311 continue; (gdb) c Continuing. ^C Program received signal SIGINT, Interrupt. 0x000000000040b197 in BuildLights () at src/tools/ufo2map/lightmap.cpp:310 310 if (VectorEmpty(p->light)) (gdb) p *p $3 = {face = 0x2f307ac , winding = 0x617eae0, origin = {4, 168.585785, 11.4142132}, normal = {-0, -0.707106829, 0.707106829}, area = 135.764496, light = {0, 0, 0}, next = 0x0} '''continue''' restart while-loop with same ''p''. Looks like ''p'' must change to ''p->next''.
Steps to reproduce this issue
#. Update to revision 2b0372858a407d4c1dfaba4f5e9d68cad4e5882b #. Launch `./ufo2map -v 4 -nice 19 -quant 4 -soft maps/shelter/shelter_room_e_b.map` #. Wait for "----- Lighting ---- Couldn't load textures/textures/tex_common/nodraw"
Comments (2)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (1)
Duplicate issues (0)