UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #450  -  Dead soldier got promoted
Posted Nov 19, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     cassiterite
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     kantorai
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 450 imported from sourceforge.net tracker on 2013-01-28 18:21:29

I have played UFO:AI since 2.0 rc3 or something like that and really enjoy the game. Thank you all for the effort!

Just downloaded rc6 (win32.exe) to try. After the third mission ended there was a message in the world view that one of the soldiers that was killed during the mission had been promoted to sergeant. I checked that there were no soldiers (or other employees) by that name. None of the surviving soldiers had been promoted.

Haven't seen this topic anywhere in the bugreport so I hope it's not a re-post.

Keep up the good work! /Nils
Comments Ported from Sourceforge  ⇑ top
cassiterite (2006-12-06 08:18:39)  ⇑ top
Logged In: YES user_id=1171370 Originator: NO

Thanks for the bug report. Should now be fixed in trunk revision 5084.

Note: Soldiers are allowed to be promoted after death, but now the message will indicate this: _Soldier X_ has been awarded the posthumous rank of _Rank Y_ for inspirational gallantry in the face of overwhelming odds.
Steps to reproduce this issue
Nothing entered.