UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #36  -  Equipment Loss When Mission Start
Posted Mar 22, 2006 - updated Jan 28, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 36 imported from sourceforge.net tracker on 2013-01-28 18:08:35

I've found a serious bug that equipment purchased before a mission will be automatically lost when the mission start.Only some weapons and ammos are left.How comes such a great bug??? How to solve that???
Comments Ported from Sourceforge  ⇑ top
killertomato (2006-03-22 12:35:06)  ⇑ top
Logged In: YES user_id=1478168

I've noticed that before the scenario is loaded, during the phase when all the text(compilation state messages?) scrolls and 5 seconds after the map is displayed there are messages stating something like: "Sniper Rifle(or any other item) not allowed so removed from inventory" or somesuch.
faucon (2006-03-23 02:39:09)  ⇑ top
Logged In: YES user_id=706397

There is something here : http://sourceforge.net/tracker/index.php?func=detail&aid=1411329&group_id=157793&atid=805242

...that look like this. But no solution there too.
dpblnt (2006-03-27 11:29:16)  ⇑ top
Logged In: YES user_id=1487075

this happens on mission restart - clicking on the "try again" button at a mission end.
hoehrer (2006-03-31 16:08:33)  ⇑ top
Logged In: YES user_id=1434318

1. What version are you using?

2. If it's compiled from SVN: Does this still happen because I can't reproduce this bug with current SVN. 1

Werner

1 except for the "try again" thing, but that's a seperate bug. See http://sourceforge.net/tracker/index.php?func=detail&aid=1461639&group_id=157793&atid=805242
nobody (2006-06-01 06:10:19)  ⇑ top
Logged In: NO

I have the same problem with: Item 'Medium Armor' not allowed and removed from inventory.
bandobraz (2006-07-25 23:04:24)  ⇑ top
Logged In: YES user_id=1557623

This (starting mission with some weapons lost) should be fixed now in trunk. Could you verify and close the bug?
killertomato (2006-08-03 18:26:33)  ⇑ top
Logged In: YES user_id=1478168

Nope. Not fixed. At least not in RC3.
bandobraz (2006-08-28 21:39:36)  ⇑ top
Logged In: YES user_id=1557623

Please reopen if this is not fixed in RC4.
Steps to reproduce this issue
Nothing entered.