UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #2631  -  Blinking/flashing textures
Posted Jul 20, 2010 - updated Jan 28, 2013
arisian (arisian) has been working on this issue since January 28, 2013 (20:47)
Issue details
  • Type of issue
    Bug report
  • Status
     
    Open
  • Assigned to
     arisian
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Guest user
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    Not determined
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 2631 imported from sourceforge.net tracker on 2013-01-28 19:43:45

2.3 release on Gentoo (built using ebuild from Portage; Thinkpad T60 w/ Mobility Radeon X1400)

Certain regions will reproducibly blink. For instance, if I start a skirmish on Large Industrial, rectangular areas slightly larger than and under both the alien ship and the drop ship will blink so long as I am zoomed a certain amount out (it stops blinking the dropship's blinking area is basically all I can see, for instance). This appears to be map dependent -- perhaps my system is freaking out about the number of textures used? e.g. I see no blinking on Africa.

Comments Ported from Sourceforge  ⇑ top
*anonymous (2010-07-20 04:47:18)  ⇑ top
Output from ufo-ai
*anonymous (2010-07-20 05:34:13)  ⇑ top
Follow-up:

Noticed something a pattern in the blinking in the Large Industrial map. It'll blink once, pause (looking normal) for a few seconds, blink five times, pause, and repeat.

Enabled texture compression; no difference.
tlh2000 (2010-08-02 05:22:29)  ⇑ top
with blinking you mean what? can you try to catch the blinking in two screenshots? is it glowing? try to disable the glsl shaders - that might help us to tackle it down (if it is disappearing after that)
andrewusu (2010-08-25 16:25:40)  ⇑ top
Does this blinking occur when the viewpoint (camera) is moved around and/or stationary?

Does it appear to be geometry that intersects each other? This could explain the suspected map dependency.

Is it only the floor that blinks?

By blink, do you mean the entire plane gets brighter then back to normal in a split second?

Is there any jaggedness like this?: http://i558.photobucket.com/albums/ss30/andrewusu/ufoai/r31875GLSL-PostProcessing.jpg
Steps to reproduce this issue
Nothing entered.