UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #2411  -  Actor gets killed before projectile actually hits him
Posted Mar 15, 2010 - updated Jan 23, 2015
crystan (crystan) has been working on this issue since January 28, 2013 (20:46)
Issue details
  • Type of issue
    Bug report
  • Status
     
    Open
  • Assigned to
     crystan
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     harper47
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    Battlescape
  • Resolution
    Not determined
  • Priority
    2. Low
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 2411 imported from sourceforge.net tracker on 2013-01-28 19:35:59

Actor gets killed before projectile is hit it. Only true to projectiles, the explosions work correct.
Comments Ported from Sourceforge  ⇑ top
tlh2000 (2010-08-21 16:16:08)  ⇑ top
this is maybe related to the weapon projectile speed and/or the particle.
crystan (2011-05-16 22:17:58)  ⇑ top
No, i dont think so.
aduke1 (2011-11-27 20:32:21)  ⇑ top
The priority was adjusted according to the "bug priority rules". See http://ufoai.ninex.info/wiki/index.php/Bugs#Bug_Priorities
tlh2000 (2011-11-28 06:38:58)  ⇑ top
... but i do ;) there is some event execution delay in the client side code - and the EV_ACTOR_DIE event is executed before the particle hit the target. And the delay for the die event is calculated with the particle speed parameter as factor (and other stuff included)
mcr2010 (2012-01-29 10:50:15)  ⇑ top
This is still valid in recent master.
Steps to reproduce this issue
Nothing entered.