UFO: Alien Invasion Issue Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #213 Crashes
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Description
[http://sourceforge.net/p/ufoai/bugs/213 Item 213] imported from sourceforge.net tracker on 2013-01-28 18:15:21 Pentium 3 768mb RAM and an ati radeon 7000 64mb VRAM following is ufoconsole.log Console initialized. ------- sound initialization ------- Using Alsa sound sampling rate: 48000 ------------------------------------ ------- Loading ref_glx.so ------- LoadLibrary("ref_glx.so"): can't open /etc/ufo.conf - setting search path to . LoadLibrary("./ref_glx.so") ref_gl version: GL 0.12 Initializing OpenGL display ...setting fullscreen mode 9: 1600 1200 Using XFree86-VidModeExtension Version 2.2 Using hardware gamma GL_VENDOR: Tungsten Graphics, Inc. GL_RENDERER: Mesa DRI Radeon 20050528 NO-TCL GL_VERSION: 1.2 Mesa 6.4.1 GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_histogram GL_EXT_packed_pixels GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_APPLE_packed_pixels GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod ...allowing CDS ...enabling GL_EXT_compiled_vertex_array ...GL_EXT_point_parameters not found ...using GL_ARB_multitexture ...using GL_EXT_texture_env_combine ...GL_SGIS_multitexture not found ...ignoring GL_ARB_texture_compression ...ignoring GL_EXT_texture_filter_anisotropic ...using GL_EXT_texture_lod_bias ...using GL_EXT_stencil_wrap ...GL_EXT_fog_coord not found ...GL_ATI_separate_stencil not found Max texture size supported ...detected 1024 ...SDL_ttf inited ------------------------------------ CDAudio_Init: No CD in drive. CDAudio_Init: CD contains no audio tracks. CD Audio Initialized. couldn't exec autoexec.cfg ...using language: C Shared Client/Server Info loaded Couldn't open 'music/theme.ogg' ...precaching 46 menus Can't find pics/ Can't find pics/menu/multi_buttons1 Can't find pics/menu/main_buttons2 Can't find pics/menu/button_connect_to_ip ====== UFO Initialized ====== Changing to Singleplayer Unknown command "selfloor-1" Couldn't open 'music/theme.ogg' ------- Loading ref_glx.so ------- LoadLibrary("ref_glx.so"): can't open /etc/ufo.conf - setting search path to . LoadLibrary("./ref_glx.so") ref_gl version: GL 0.12 Cmd_AddCommand: fontcachelist already defined Initializing OpenGL display ...setting mode 9: 1600 1200 Using XFree86-VidModeExtension Version 2.2 GL_VENDOR: Tungsten Graphics, Inc. GL_RENDERER: Mesa DRI Radeon 20050528 NO-TCL GL_VERSION: 1.2 Mesa 6.4.1 GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_histogram GL_EXT_packed_pixels GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_subtexture next is the config.cfg which i did not modify // generated by ufo, do not modify set s_language "C" set cl_vwep "1" set msg "1" set rate "25000" set teamnum "1" set equip "standard" set team "human" set name "unnamed" set mn_lastsave "slot0" set mn_hud "hud" set confirm_actions "0" set difficulty "3" set cl_shownet "0" set cl_fps "0" set cl_aviMotionJpeg "1" set cl_aviFrameRate "25" set cl_markactors "1" set lookspring "0" set cl_run "0" set cl_show_tooltips "1" set cl_stereo_separation "0.4" set adr8 "" set adr7 "" set adr6 "" set adr5 "" set adr4 "" set adr3 "" set adr2 "" set adr1 "" set adr0 "" set cd_volume "1" set cd_nocd "0" set viewsize "100" set cursor "1" set intensity "2" set r_fakeFullscreen "0" set vid_grabmouse "1" set gl_3dlabs_broken "1" set gl_swapinterval "1" set gl_ext_s3tc_compression "1" set gl_ext_texture_compression "0" set gl_ext_compiled_vertex_array "1" set gl_ext_pointparameters "1" set gl_ext_combine "1" set gl_ext_multitexture "1" set gl_ext_palettedtexture "1" set gl_ext_swapinterval "1" set gl_vertex_arrays "0" set gl_fog "1" set gl_texturesolidmode "default" set gl_texturealphamode "default" set gl_texturemode "GL_LINEAR_MIPMAP_NEAREST" set gl_finish "1" set gl_maxtexres "1024" set gl_embossfilter "0" set r_stencil_two_side "1" set r_ati_separate_stencil "0" set r_shadow_debug_shade "0" set r_shadow_debug_volume "0" set gl_shadows "1" set gl_bitdepth "0" set gl_modulate "1" set gl_particle_att_c "0.01" set gl_particle_att_b "0.0" set gl_particle_att_a "0.01" set gl_particle_size "40" set gl_particle_max_size "40" set gl_particle_min_size "2" set r_texture_lod "0" set r_anisotropic "0" set r_displayrefresh "0" set hand "0" set m_pitch "0.022" set sensitivity "2" set lookstrafe "0" set freelook "0" set in_dgamouse "0" set in_mouse "1" set vid_gamma "1" set vid_ypos "22" set vid_xpos "3" set s_system "2" set snddevice "default" set sndchannels "2" set sndspeed "0" set sndbits "16" set ov_volume "0.5" set s_mixahead "0.2" set s_loadas8bit "0" set s_khz "44" set s_volume "0.7" set sv_reconnect_limit "3" set maxsoldiersperplayer "8" set maxsoldiers "4" set sv_enablemorale "1" set hostname "noname" set cl_precachemenus "1" set vid_fullscreen "1" set gl_mode "9" set gl_driver "libGL.so.1" set vid_ref "glx" get ahold of me at moonunit2008@gmail.com ===== Comments Ported from Sourceforge ===== ====== bandobraz (2006-08-04 18:48:31) ====== Logged In: YES user_id=1557623 This is from http://ufo.myexp.de/phpBB2/viewtopic.php?p=2390#2390 ====== cassiterite (2006-10-02 05:18:22) ====== Logged In: YES user_id=1171370 According to your forum post you are running Ubuntu Dapper Drake (I'm also currently running this). I see the game is reporting "GL_VENDOR: Tungsten Graphics, Inc.". If you have installed the binary proprietry ATI drivers you should get "GL_VENDOR: ATI Technologies Inc.". Unfortunately the game just won't run using the opensource ATI drivers yet... and possibly there are problems with other binary drivers from 3rd parties. Please retry the game using ATI's proprietry drivers (also upgrade to RC5 or later). I'm closing this bug and marking it as "works for me" (since I have an ATI card which is running the game fine under Dapper Drake). If you can't get the game running after installing the ATI binary drivers or discover anything new, please leave a comment on this this bug report (and I will re-open it if needed). For example if the drivers you currently have installed allow you to play other complex 3D games (like Nexiuz for example) then this crash may indicate a problem specific to ufo:ai.
Steps to reproduce this issue
Nothing entered.
Comments (0)
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Engine
  • Targetted for
    Not determined
  • Status
    Closed
  • Priority
    3. Normal
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
  • Estimated time
    Not estimated
Issue details
  • Resolution
    Not determined
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Complexity
    Not determined
  • Platform
    Not determined
  • Architecture
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)