project-navigation
Personal tools

Author Topic: ERROR: Actor is still moving  (Read 14018 times)

8472

  • Guest
Re: ERROR: Actor is still moving - R25466
« Reply #15 on: July 28, 2009, 12:17:16 pm »
yes - this and the "Actor is dead" bug should be fixed - if not, please let us know.


problem look like to be solved in R25466
thx

8472

  • Guest
Re: ERROR: Actor is still moving - R25479
« Reply #16 on: July 29, 2009, 06:15:15 pm »
R25479

looks like problem is back, I just entered a new crashed UFO mission (a supply ship), when the game crashed back to the GEOSCAPE at the time of alien round.

[there you have a save game attached (named save.tar.bz2), import and simply run the time and wait for a mission]

Quote
checksum for the map '+ufocrash': 3530836437
ufo script checksum 3688974846
Not enough spawn points for team 0
Created AI player (team 0)
Not enough spawn points for team 7
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/ufocrash.mat'
music change to AlexFightmare (from karlmacklin_geoscape)
Starting the game...
__8472 has joined team 0
(player 0) It's team 1's round
__8472 has taken control over team 1.
music change to PsymongN2 (from AlexFightmare)
Team 1 ended round, team 7's round started!
********************
ERROR: Actor is still moving
********************
Shutdown server: Server crashed.
==== ShutdownGame ====
./ufo(Sys_Backtrace+0x1f)[0x819241a]
./ufo(Com_Error+0xdf)[0x813f762]
./ufo(CL_ActorDoMove+0xcf)[0x809c8c1]
./ufo[0x809ad10]
./ufo(Qcommon_Frame+0x9a)[0x8141433]
./ufo(main+0x66)[0x819117d]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7723775]
./ufo[0x8069fc1]
music change to van_geoscape (from PsymongN2)
Shutdown gametype 'Campaign mode'
Cmd_RemoveCommand: messagetypes_click not added
Cvar 'mn_uprequirement' wasn't found
Cvar 'mn_upmetadata' wasn't found
music change to van_theme (from van_geoscape)

EDIT1:
right now same crash to GEOSCAPE appeared to me, but in a different UFO crash mission (a harvester ship)
Quote
checksum for the map '+ufocrash': 3519718333
ufo script checksum 3688974846
Not enough spawn points for team 0
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/ufocrash.mat'
music change to van_mission2 (from ufo1)
Starting the game...
__8472 has joined team 0
(player 0) It's team 1's round
__8472 has taken control over team 1.
music change to ufo2 (from van_mission2)
Team 1 ended round, team 7's round started!
********************
ERROR: Actor is still moving
********************
Shutdown server: Server crashed.
==== ShutdownGame ====
./ufo(Sys_Backtrace+0x1f)[0x819241a]
./ufo(Com_Error+0xdf)[0x813f762]
./ufo(CL_ActorDoMove+0xcf)[0x809c8c1]
./ufo[0x809ad10]
./ufo(Qcommon_Frame+0x9a)[0x8141433]
./ufo(main+0x66)[0x819117d]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7802775]
./ufo[0x8069fc1]
music change to karlmacklin_geoscape (from ufo2)
music change to van_geoscape (from karlmacklin_geoscape)
Loading savegame xml (size 146562)
Loading savegame
...version: 3
...game version: 2.3-dev
...xml Size: 2110825, compressed? y
Shutdown gametype 'Campaign mode'
Cmd_RemoveCommand: messagetypes_click not added
Cvar 'mn_uprequirement' wasn't found
Cvar 'mn_upmetadata' wasn't found
Change gametype to 'Campaign mode'
[save game named save2.tar.bz2 attached]

EDIT2:
I've found, that it's strange with the first case (the crashed supply ship) mentioned. In this mission I was finally able to finish it on another attempt.
But with that second case (the crashed havester ship) it wasn't that easy, and still can't finish it.

EDIT3:
Well, finally i managed to finish that harvester mission too, but on 3rd or 4th attempt.
So this "Actor is still moving" is not on the same "level" as those previous one's.

EDIT4:
R25485
damn it, another game crash to the GEOSCAPE, this time a crashed FIGHTER on a different contitent.
Quote
checksum for the map '+ufocrash': 13765724
ufo script checksum 3688974846
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/ufocrash.mat'
music change to PsymongR3 (from van_geoscape)
Starting the game...
__8472 has joined team 0
(player 0) It's team 1's round
__8472 has taken control over team 1.
music change to PsymongR3 (from PsymongR3)
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Krrnaak Uk Kronok is consumed by mad rage!
Team 1 ended round, team 7's round started!
********************
ERROR: Actor is still moving
********************
Shutdown server: Server crashed.
==== ShutdownGame ====
./ufo(Sys_Backtrace+0x1f)[0x819241a]
./ufo(Com_Error+0xdf)[0x813f762]
./ufo(CL_ActorDoMove+0xcf)[0x809c8c1]
./ufo[0x809ad10]
./ufo(Qcommon_Frame+0x9a)[0x8141433]
./ufo(main+0x66)[0x819117d]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb77c8775]
./ufo[0x8069fc1]
music change to karlmacklin_geoscape (from PsymongR3)
Shutdown gametype 'Campaign mode'
Cmd_RemoveCommand: messagetypes_click not added
Cvar 'mn_uprequirement' wasn't found
Cvar 'mn_upmetadata' wasn't found
music change to van_theme (from karlmacklin_geoscape)
[save game named save3.tar.bz2 attached]
« Last Edit: July 29, 2009, 07:50:39 pm by 8472 »

Offline frr

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: ERROR: Actor is still moving
« Reply #17 on: August 10, 2009, 11:59:34 pm »
Okay, I've tried version 25602 (fresh from SVN) and guess what: first crashed UFO, made a savegame from Geoscape just before entering Battlescape, shuffled my team about a bit, clicked "next turn" and here it was:
  ERROR: Actor on team 7 is still moving (3 steps left)
A full listing of the ufoai stdout and stderr for the session is attached.

My system configuration:
Fedora 10 64bit on a cheap all-Intel notebook
i965GM, integrated Intel graphics, C2D CPU, 2 GB RAM.

Unfortunately, it doesn't seem very reproducible.
I went on to re-load the savegame just before entering the Battlescape, typed "setdeveloper DEBUG_EVENTSYS" into the console, and voila: the bug didn't re-surface. This was perhaps my first ufo crash recovery mission that I managed to finish (without a ufoai crash).

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: ERROR: Actor is still moving
« Reply #18 on: August 18, 2009, 01:51:42 am »
Connecting to localhost...
load material file: 'materials/farm.mat'
music change to dawn (from karlmacklin_geoscape)
Starting the game...
gerald has joined team 0
(player 0) It's team 1's round
gerald has taken control over team 1.
music change to PsymongR2 (from dawn)
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
********************
ERROR: Actor on team 7 is still moving (8 steps left)
********************
Shutdown server: Server crashed.

[/quote]
win Xp system
ver 2.3.3 25557 crash after ending my turn,map berlin +farm,terror mission harvester ship.
also game behave strange as in topic "strange behavior",aliens try shoot from inside their ship
and screen jumping chaotically ,big laggs in aliens&civ turn .
« Last Edit: August 18, 2009, 11:24:05 am by gerald »

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: ERROR: Actor is still moving
« Reply #19 on: August 19, 2009, 12:41:46 am »
next one here
Connecting to localhost...
load material file: 'materials/tropic.mat'
music change to David02 (from karlmacklin_geoscape)
Starting the game...
gerald has joined team 0
(player 0) It's team 1's round
gerald has taken control over team 1.
music change to PsymongO4 (from David02)
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
********************
ERROR: Actor on team 7 is still moving (2 steps left)
********************
Shutdown server: Server crashed.
==== ShutdownGame ====

bangkok tropical drug map harvester ship also saw weird effect like screen trying follow no visible aliens shoots,it first move to alien ship then jump in direction of my soldiers anyway no plasma hits visible on wall or no shoot sound

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2553
    • View Profile
Re: ERROR: Actor is still moving
« Reply #20 on: August 19, 2009, 01:16:28 am »
For this bug the latest about 20 lines of events.log would be usefull.

Currently noone can fix this bug as active developers - or at least me - have no idea how event system works, sorry. Bit more patience, please.

-geever

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: ERROR: Actor is still moving
« Reply #21 on: August 19, 2009, 01:34:36 am »
all good :) i've posted that so i thought giving console logs from certain maps may help i wont spamming here ,i've got that bug in 4 ufo landings&crashing in row now so pls write if posting console logs will help with something.
sure thing ill post longer logs.

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: ERROR: Actor is still moving
« Reply #22 on: August 23, 2009, 06:47:50 pm »
Loaded routing for tile tropic/tr_f06 in   0.0s
Map:tropic/tr_f07  Offset:(16, 16, 0)
wpMins:(128, 128, 0) wpMaxs:(135, 135, 2)
Shifted wpMins:(144, 144, 0) wpMaxs:(151, 151, 2)
Tile bounds: (144, 144, 0) to (151, 151, 2)
Source bounds: (128, 128, 0) to (135, 135, 2)
Done copying data.
Loaded routing for tile tropic/tr_f07 in   1.0s
Map:tropic/tr_f02  Offset:(16, 8, 0)
wpMins:(128, 128, 0) wpMaxs:(135, 135, 2)
Shifted wpMins:(144, 136, 0) wpMaxs:(151, 143, 2)
Tile bounds: (144, 136, 0) to (151, 143, 2)
Source bounds: (128, 128, 0) to (135, 135, 2)
Done copying data.
Loaded routing for tile tropic/tr_f02 in   0.0s
Rerouted for RMA in   0.0s
checksum for the map '+tropic': 878550369
ufo script checksum 2405305234
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/tropic.mat'
music change to David04 (from karlmacklin_geoscape)
Starting the game...
gerald has joined team 0
(player 0) It's team 1's round
gerald has taken control over team 1.
music change to alBasrahM (from David04)
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
********************
ERROR: Actor on team 7 is still moving (2 steps left)
********************
Shutdown server: Server crashed.

ver 25745 tropical+drug
« Last Edit: August 24, 2009, 02:15:37 am by gerald »

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: ERROR: Actor is still moving
« Reply #23 on: August 24, 2009, 01:12:14 am »
Im playing R.V. 25745 and getting these

odie

  • Guest
Re: ERROR: Actor is still moving
« Reply #24 on: August 24, 2009, 07:41:40 am »
For this bug the latest about 20 lines of events.log would be usefull.

Currently noone can fix this bug as active developers - or at least me - have no idea how event system works, sorry. Bit more patience, please.

-geever

geever,

Any chance you could point me to the source file for events management pls?

:D

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: ERROR: Actor is still moving
« Reply #25 on: August 24, 2009, 07:42:45 am »
src/client/events

the bad file is e_time.c

Offline Nightknight

  • Rookie
  • ***
  • Posts: 25
    • View Profile
Re: ERROR: Actor is still moving
« Reply #26 on: August 26, 2009, 07:38:14 pm »

Game Version:
Game Downloaded via "svn co https://ufoai.svn.sourceforge.net/svnroot/ufoai/ufoai/trunk"
Output of "svn info"
Path:
URL: https://ufoai.svn.sourceforge.net/svnroot/ufoai/ufoai/trunk
Repository Root: https://ufoai.svn.sourceforge.net/svnroot/ufoai
Repository UUID: 39b98707-f80d-0410-bc7e-c6b02f5409da
Revision: 25831
Node Kind: directory
Schedule: normal
Last Changed Author: geever
Last Changed Rev: 25831
Last Changed Date: 2009-08-24 16:50:50 -0430 (Mon, 24 Aug 2009)

System Information:
OS: Ubuntu 9.04 "Jaunty Jackalope"
Kernel "2.6.28-15-generic"
GPU: nVIDIA Gforce 8800gt 512mb DDR3
"01:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)" Driver: NVIDIA Accelerated Graphics Driver (Version 180)
Arch: AMD64
(Output of "uname -a"): Linux Anastasia 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009 x86_64 GNU/Linux

What happened before the bug occurred? Is the bug reproducible?
- Loaded game (from ~) "cd /usr/share/games/ufoai/trunk && gdb ufo"
- Started with run +set vid_fullscreen 0 +set vid_grabmouse 0 +set developer 1
- Loaded Game /Entered Mission (Crashed UFO - Fighter @ No nation)/ Completed "Round 1" -- Crash.

Useful files:
http://www.filefactory.com/file/complete.php/ah369cc/ah369cd/ah369cg/

Contains: "bt full" output / Last lines of events.log / Last lines of terminal output.

Offline polyvios

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: ERROR: Actor is still moving
« Reply #27 on: August 27, 2009, 12:29:49 am »
I reproduced the crash while running the game in GDB.  I'm using ubuntu 9.04 with 2.6.28-15-generic kernel, on an intel 64 bit dual core.
Here's the stack trace:
Code: [Select]
(gdb) bt
#0  0x000000000053855f in INVSH_EmptyContainer (i=0x2da0e08, container=0x6281144) at src/game/inv_shared.c:1060
#1  0x000000000044d41a in LE_Cleanup () at src/client/cl_le.c:1128
#2  0x000000000043594a in GAME_Drop () at src/client/cl_game.c:464
#3  0x000000000044e1ca in CL_Drop () at src/client/cl_main.c:178
#4  0x0000000000508b32 in Com_Error (code=1, fmt=0x574b28 "Actor (entnum: %i) on team %i is still moving (%i steps left)") at src/common/common.c:240
#5  0x000000000045cfd2 in CL_ActorDoMove (self=0x574038, msg=0x13284908) at src/client/events/event/actor/e_event_actormove.c:79
#6  0x000000000045b23b in CL_ExecuteBattlescapeEvent (now=1415126, data=0x20b64348) at src/client/events/e_parse.c:112
#7  0x000000000050a7a5 in Qcommon_Frame () at src/common/common.c:1127
#8  0x0000000000563801 in main (argc=1, argv=0x7fffc2b9ff28) at src/ports/linux/linux_main.c:53

the whole event struct, I broke each field into a line (C-sytax style):
Code: [Select]
(gdb) p *le
$7 = {
  inuse = qtrue,
  invis = qfalse,
  selected = qfalse,
  type = 2,
  entnum = 2,
  origin = {-624, 848, 36},
  oldOrigin = {0, 0, 0},
  pos = "l\232",
  oldPos = "l\232",
  newPos = "l\231",
  dir = 5,
  TU = 0,
  maxTU = 32,
  morale = 0,
  maxMorale = 100,
  HP = 0,
  maxHP = 100,
  STUN = 0,
  state = 0,
  oldstate = 0,
  angles = {0, 225, 0},
  alpha = 0,
  team = 7,
  pnum = 9,
  currentSelectedFiremode = 0,
  actorMode = M_MOVE,
  mousePendPos = "\000\000",
  actorMoveLength = 0 '\0',
  clientAction = 0,
  contents = 8388608,
  mins = {-9, -9, -24},
  maxs = {9, 9, 20},
  inlineModelName = "\000\000\000\000\000\000\000",
  modelnum1 = 16,
  modelnum2 = 17,
  skinnum = 1,
  model1 = 0xfcfc440,
  model2 = 0xfcfc6b8,
  think = 0x44bb22 <LET_StartPathMove>,
  thinkDelay = 0,
  path = "\030 ",
  '\0' <repeats 29 times>,
  pathContents = {0 <repeats 32 times>},
  positionContents = 0,
  pathLength = 1,
  pathPos = 0,
  startTime = 1414627,
  endTime = 1414627,
  speed = {321, 321, 0 <repeats 30 times>},
  rotationSpeed = 0,
  sample = 0x0,
  volume = 0,
  as = {
    frame = 190,
    oldframe = 189,
    backlerp = 0.662999988,
    time = 1000,
    dt = 337,
    mesh = 0,
    list = "\032#\032\033\032#\032",
    lcur = 6 '\006',
    ladd = 7 '\a',
    change = 0 '\0'},
  particleID = 0x0,
  levelflags = 0,
  ptl = 0x0,
  ref1 = 0x0,
  ref2 = 0x0,
  i = {c = {0x0 <repeats 16 times>}},
  left = 109,
  right = 109,
  extension = 0,
  headgear = 0,
  fieldSize = 1,
  teamDef = 0x62951f0,
  gender = 0,
  fd = 0x0,
  pathMap = 0x0,
  lighting = {
    origin = {-624, 848, 36},
    point = {-624, 848, 4.03125},
    normal = {0, 0, 1},
    color = {1, 1, 1},
    position = {0, 0, 0},
    time = 1403.11206,
    colors = {{1, 1, 1}, {1, 1, 1}},
    positions = {{0, 0, 0}, {0, 0, 0}}, dirty = qfalse},
  addFunc = 0x42ccaf <CL_AddActor>
}

the arguments to the move function:
Code: [Select]
(gdb) p *self
$11 = {type = 15, name = 0x573c26 "EV_ACTOR_MOVE", formatString = 0x573c34 "!sbbs", eventCallback = 0x45cee7 <CL_ActorDoMove>, timeCallback = 0x45ced0 <CL_ActorDoMoveTime>}
(gdb) p *msg
$12 = {len = 15, space = 3985, head = 0x29130628, tail = 0x29130628, start = 0x29130632 "\002j\230", end = 0x29130641 "", next_free = 0x0}

Reminder, function pointers are printed both as 0xXXXXX address and as the name of the function in that address (if known at runtime).  Strings are printed by address and by content (when the C-source type is char*).

Hope it helps.  Cheers for a nice game.

Offline Wace

  • Rookie
  • ***
  • Posts: 14
    • View Profile
Re: ERROR: Actor is still moving
« Reply #28 on: August 28, 2009, 10:19:50 am »
Just got the same error on the latest (25872) version:
Code: [Select]
ERROR: Actor (entnum: 12) on team 7 is still moving (1 steps left)
********************
Shutdown server: Server crashed.
==== ShutdownGame ====
./ufo(Sys_Backtrace+0x1f)[0x81954f2]
./ufo[0x8195552]
[0xb7f56400]
./ufo(LE_Cleanup+0x140)[0x808d153]
./ufo(GAME_Drop+0x13)[0x8075f5e]
./ufo(CL_Drop+0x10)[0x808dbce]
./ufo(Com_Error+0xd0)[0x8142293]
./ufo(CL_ActorDoMove+0xfa)[0x809c8bc]
./ufo[0x809aca4]
./ufo(Qcommon_Frame+0x9a)[0x8143f73]
./ufo(main+0x66)[0x8194255]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7909775]
./ufo[0x806a261]
./ufo(Sys_Backtrace+0x1f)[0x81954f2]
./ufo(Sys_Error+0x22)[0x819466c]
./ufo(Sys_InitSignals+0x0)[0x8195565]
[0xb7f56400]
./ufo(LE_Cleanup+0x140)[0x808d153]
./ufo(GAME_Drop+0x13)[0x8075f5e]
./ufo(CL_Drop+0x10)[0x808dbce]
./ufo(Com_Error+0xd0)[0x8142293]
./ufo(CL_ActorDoMove+0xfa)[0x809c8bc]
./ufo[0x809aca4]
./ufo(Qcommon_Frame+0x9a)[0x8143f73]
./ufo(main+0x66)[0x8194255]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7909775]
./ufo[0x806a261]
Error: Received signal 11.
Ubuntu 9.04,  Intel(R) Celeron(R) CPU 2.53GHz, Radeon 9200 SE

Just so that I won't post possibly useless information: how do you know that bugs are fixed? Is the posting on the forum updated or should I check some kind of tracker?

Offline gerald

  • Rookie
  • ***
  • Posts: 79
    • View Profile
Re: ERROR: Actor is still moving
« Reply #29 on: August 28, 2009, 03:25:36 pm »
Done copying data.
Loaded routing for tile tropic/tr_f07 in   0.0s
Map:tropic/tr_f02  Offset:(-8, 24, 0)
wpMins:(128, 128, 0) wpMaxs:(135, 135, 2)
Shifted wpMins:(120, 152, 0) wpMaxs:(127, 159, 2)
Tile bounds: (120, 152, 0) to (127, 159, 2)
Source bounds: (128, 128, 0) to (135, 135, 2)
Done copying data.
Loaded routing for tile tropic/tr_f02 in   1.0s
Rerouted for RMA in   0.0s
checksum for the map '+tropic': 2841585622
ufo script checksum 2100944313
Not enough spawn points for team 0
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/tropic.mat'
music change to ufo2 (from van_geoscape)
Starting the game...
gerald has joined team 0
(player 0) It's team 1's round
gerald has taken control over team 1.
music change to PsymongO5 (from ufo2)
Team 1 ended round, team 7's round started!
********************
ERROR: Actor (entnum: 66) on team 7 is still moving (1 steps left)
********************
Shutdown server: Server crashed.
==== ShutdownGame ====
music change to van_geoscape (from PsymongO5)
Shutdown gametype 'Campaign mode'
music change to van_theme (from van_geoscape)
Wrote config.cfg.
Wrote keys.cfg

ver 25862 it seems actor still in action 1st terror mission Bangkok jungle river map