project-navigation
Personal tools

Author Topic: Bridge01 map  (Read 11415 times)

Offline lfloden

  • Rookie
  • ***
  • Posts: 68
    • View Profile
That fixed the directory problem, but....
« Reply #15 on: February 22, 2007, 02:04:50 am »
Now I get this...

MAX_MAP_LEAFFACES
GetLastError() = 2

I added this to the compile.pl

my $extra = "-bounce 0 -chop 32 -extra -threads 1";

to tell it to use one thread. It is only running at 50% now for the CPU"s" so I think the thread problem is fixed, plus it is a different error now.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Bridge01 map
« Reply #16 on: February 22, 2007, 11:07:28 am »
please retry with the latest revision - this would give a little better error message (prints the overflow int) - maybe this would help me to track this bug down

Offline lfloden

  • Rookie
  • ***
  • Posts: 68
    • View Profile
Bridge01 map
« Reply #17 on: February 23, 2007, 05:40:40 am »
Here is the perl screen

Giving base/maps as parameter or start from base/maps
will compile all maps were no bsp-file exists
Keep in mind that ufo2map needs to be in path
=====================================================
Running at: MSWin32
Found ufo2map in "../../ufo2map.exe"
...entering .
..found ./africa04d
---- ufo2map 1.0 ----
subdivide_size = 32.000000
light bounces = 0
extrasamples = true
...map: 'C:\UFOAI\base\maps\./africa04d.map'
...bsp: 'C:\UFOAI\base\maps\./africa04d.bsp'
entering C:\UFOAI\base\maps\./africa04d.map
Entity 0, Brush 43: mixed face contents (f: 1, 65025)
Entity 0, Brush 44: mixed face contents (f: 1, 65025)
Entity 0, Brush 221: mixed face contents (f: 1, 65281)
Entity 0, Brush 222: mixed face contents (f: 1, 65281)
Entity 0, Brush 223: mixed face contents (f: 1, 65281)
Entity 0, Brush 224: mixed face contents (f: 1, 65281)
Entity 0, Brush 225: mixed face contents (f: 1, 65281)
Entity 0, Brush 525: mixed face contents (f: 65025, 1)
Entity 0, Brush 526: mixed face contents (f: 65025, 1)
0...

And here is the error..

MAX_MAP_LEAFFACES (65536)
GetLastError() = 2

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Bridge01 map
« Reply #18 on: February 23, 2007, 06:59:41 am »
which compiler are you using to compile ufo2map? dev-cpp (gcc)? visualC?

Offline lfloden

  • Rookie
  • ***
  • Posts: 68
    • View Profile
Bridge01 map
« Reply #19 on: February 25, 2007, 02:36:41 am »
dev-cpp

I don't even see it in the ufo_8 project for Visual C++.

Offline lfloden

  • Rookie
  • ***
  • Posts: 68
    • View Profile
Bridge01 map
« Reply #20 on: February 25, 2007, 11:10:06 pm »
OK, I finally dug a little and ran the command line for ufo2map rather than use compile.pl and it appears to be running just fine. So I think the problem might be in compile.pl

I changed this line in compile.pl and it seems to be working better...

my $extra = "-bounce 0 -threads 1 -extra ";

I got rid of the -chop 32 or was it chomp? and moved the -threads 1 before the -extra. And it is only using 1 thread now.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Bridge01 map
« Reply #21 on: February 26, 2007, 07:04:59 am »
if the chop was or is the reason, could you please also try to remove the -threads 1 parameter?

Offline lfloden

  • Rookie
  • ***
  • Posts: 68
    • View Profile
Bridge01 map
« Reply #22 on: February 27, 2007, 03:31:06 am »
With the -thread 1 out of there it still works, only uses one CPU though. That I don't mind. At least it is fixed now.