project-navigation
Personal tools

Author Topic: Problem after updatin  (Read 3712 times)

Offline Ben

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Problem after updatin
« on: December 12, 2016, 05:49:15 am »
I updated my UFO AI Game version 2.5 Tortoise. After the update I couldnt start the game anymore, because following massage showed up:

----------- parse scripts ----------
59 script files

Com_ParseGameTypes: gametype "1on1" without cvarlist

I deinstalled and installed it several times... without the update it works, with the update not...
Can anyone help me?


Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Re: Problem after updatin
« Reply #1 on: December 12, 2016, 12:12:21 pm »
Let me guess wildly:
Did you originally get the git repository (TortoiseGit ?) and then downloaded and added a .exe ?
If so, you need to have your local repository on the same state (or date) as the executable. Updating only the repo can fail, since the two must match.
If there's no new .exe available for download, you can't update (or need to compile yourself).
« Last Edit: December 12, 2016, 12:16:41 pm by anonymissimus »

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 747
    • View Profile
Re: Problem after updatin
« Reply #2 on: December 12, 2016, 04:09:12 pm »
And to follow on that, be sure to not be mixing an 2.6-dev exe with the 2.5 data (from git as guessed above?) that won't work

Also, it would be easier to help if you give more details, how did you get the game, where this upgrade you mention comes from, etc.

Offline Ben

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Problem after updatin
« Reply #3 on: December 13, 2016, 10:45:45 am »
Thanks for fast reply!
I downloaded the 2.5 Version from this page, I have the latest TortoiseSVN version, and followed the steps you can find under

http://ufoai.org/wiki/TortoiseSVN

So I put in  URL of repository

https://ufoai.svn.sourceforge.net/svnroot/ufoai/ufoai/trunk

Some files got versionised and some added.
I updated it directly in the game folder, should I have it downloaded it in another folder and than added it from there?

Do I need to download a new ufo.exe data?
I still have the ufo.exe from the 14.04.2014...
It wasn't updated...
where can I get a new exe?

Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Re: Problem after updatin
« Reply #4 on: December 13, 2016, 11:31:11 am »
The svn repo is currently outdate/no longer used, and IIRC this was the case at the time of release of 2.5 already. UFO:AI is hosted at github.

Since you already know TortoiseSVN I suggest you get TortoiseGIT instead.
The 2.6 branch is usually stable enough for playing but you can also check out the 2.5 branch. You probably won't get newer exes for it than the last release though, other than for the 2.6 branch.
« Last Edit: December 13, 2016, 11:43:55 am by anonymissimus »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Problem after updatin
« Reply #5 on: December 13, 2016, 07:48:19 pm »
The svn repo is currently outdate/no longer used, and IIRC this was the case at the time of release of 2.5 already. UFO:AI is hosted at github.

Correction: The main Git repository is still on SourceForge, GitHub is a mirror site for us.

-geever

Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Re: Problem after updatin
« Reply #6 on: December 14, 2016, 12:38:33 am »
Huh - but http://ufoai.org/wiki/Getting_the_source references github as the remote host ? And I can see your recent commits being pushed there ? Are the two automatically synchronized each night or so ?

Anyway, using a svn repo must mean using an outdated repo, independently from what its remote is.

Offline Ben

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Problem after updatin
« Reply #7 on: December 14, 2016, 09:18:15 am »
I downloaded  TortoiseGIT, how to update?
Can I update 2.5?
The changes wich are talked about in the news are changes for 2.5 or 2.6?

Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Re: Problem after updatin
« Reply #8 on: December 14, 2016, 10:19:26 am »
You cannot update an svn repo into a git one.
In the command line you'd use the command given under http://ufoai.org/wiki/Getting_the_source. In the UI there is supposedly some clone command with a field to enter that url.