project-navigation
Personal tools

Author Topic: Debian/Ubuntu packages for i386/amd64  (Read 40451 times)

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Debian/Ubuntu packages for i386/amd64
« on: October 16, 2011, 04:03:28 pm »
I've uploaded i386 and amd64 debian squeeze packages (should also work on ubuntu) to the snapshots dir

Feedback is needed on these packages. Are they working at all on your system? If not, please attach your ufoconsole.log (~/.ufoai/2.4-dev/base) here. We would like to release deb packages with the 2.4 version.

amd64
i386

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Debian/Ubuntu packages for i386/amd64
« Reply #1 on: October 28, 2011, 08:32:47 pm »
i've updated the packages and fixed some font bugs of the old ones - please try them and report problems.

Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #2 on: November 08, 2011, 04:28:12 pm »
i've updated the packages and fixed some font bugs of the old ones - please try them and report problems.

i did try the 64.deb version on my Ubuntu 11.10 and i got stuck on binutils


$ sudo dpkg -i ufoai_2.4-dev_amd64.deb
Selecting previously deselected package ufoai.
(Reading database ... 341838 files and directories currently installed.)
Unpacking ufoai (from ufoai_2.4-dev_amd64.deb) ...
dpkg: dependency problems prevent configuration of ufoai:
 ufoai depends on binutils (<< 2.20.2); however:
  Version of binutils on system is 2.21.53.20110810-0ubuntu5.
dpkg: error processing ufoai (--install):
 dependency problems - leaving unconfigured


uname -a
Linux 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

EDIT: i did try to fake it with a symbolic link but it didnt work:) i got same error
« Last Edit: November 08, 2011, 04:36:08 pm by wizardelo »

Offline Davren13

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #3 on: November 13, 2011, 01:34:38 am »
I also tried the amd64 deb on Ubuntu 11.10 x64 and got stuck on binutils

$ sudo dpkg -i ufoai_2.4-dev_amd64.deb
Selecting previously deselected package ufoai.
(Reading database ... 147760 files and directories currently installed.)
Unpacking ufoai (from ufoai_2.4-dev_amd64.deb) ...
dpkg: dependency problems prevent configuration of ufoai:
 ufoai depends on binutils (<< 2.20.2); however:
  Version of binutils on system is 2.21.53.20110810-0ubuntu5.
dpkg: error processing ufoai (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Errors were encountered while processing:
 ufoai


uname -a
Linux requiem 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
« Last Edit: November 13, 2011, 03:41:14 am by Davren13 »

Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #4 on: December 13, 2011, 12:03:36 pm »
any updates?

Offline shag

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #5 on: January 17, 2012, 05:12:49 pm »
Works mostly fine on my oneiric amd64 laptop w. intel graphics.

1) I had to force install with dpkg --force-depends though, and symlink /usr/lib/libbfd-2.20.1-system.20100303.so to /usr/lib/libbfd-2.21.53-system.20110810.so
2) In ~30 hours of playing I have seen 1 crash in the earth view, and 1 crash in the tactical mode

I am now building ubuntu oneiric packages from recent git. Will post links here when I confirm working game client.


Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #6 on: January 18, 2012, 08:33:53 am »
Works mostly fine on my oneiric amd64 laptop w. intel graphics.

1) I had to force install with dpkg --force-depends though, and symlink /usr/lib/libbfd-2.20.1-system.20100303.so to /usr/lib/libbfd-2.21.53-system.20110810.so
2) In ~30 hours of playing I have seen 1 crash in the earth view, and 1 crash in the tactical mode

I am now building ubuntu oneiric packages from recent git. Will post links here when I confirm working game client.

I managed to build up a git version also but before december update, if ya can make .deb , i would apreciate it. tnx

Offline shag

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #7 on: January 18, 2012, 02:12:53 pm »
AMD64 oneiric packages of 2.4-dev are here :

http://www.outrightsolutions.nl/~sander/ubuntu/ufoai/

Built from git from 2012-01-17

I had to make one adjustment to my ~/.ufoai/.../config.cfg, which was created by the existing debian 2.4-dev deb. I had to set ui_hunksize to 4 (from 2). I don't know if these new packages create the right default if config.cfg does not exist, haven't tested that yet..

Have fun!


Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #8 on: January 18, 2012, 02:17:15 pm »
Hey shag :)

Welcome to the forums !

Cool, that you are using the "Oneiric Oncelot" already  8)

Edit: I mixed up "Oneiric Oncelot" and "Precise Pangolin" ;)
« Last Edit: January 18, 2012, 02:38:46 pm by MCR »

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #9 on: January 18, 2012, 02:20:46 pm »
btw, ui_hunksize has already been removed and changed to dynamic memory allocation AFAIK, so this should not be needed anymore:

http://ufoai.git.sourceforge.net/git/gitweb.cgi?p=ufoai/ufoai;a=commit;h=57a697251a85f966fbf32b0068eefc9b5004ecfe

Offline shag

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #10 on: January 18, 2012, 02:23:54 pm »
Hi! :)

Strange.. after installing the deb and running the game it exited with an error about ui_hunksize being too small.. maybe if the var is defined it still uses it and does checks on it..

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #11 on: January 18, 2012, 02:35:24 pm »
Remove the ui_hunksize definition from the config.cfg file in .ufoai/base.
Also remove keys.cfg so it will be rewritten by the game, because there have been changes to this file as well...

The game does not do that automatically so probably there are remains left from your previous installation there...

Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #12 on: January 19, 2012, 08:16:45 am »
i had same problem, so i moved .ufoai folder somewhere else and it created new keys and config files and worked no problem.

on topic: i tried to make deb from latest git and i got error missing ufo manual.pdf :)
file i got is "ufo-manual_EN.tex"

Code: [Select]

cp: cannot stat `./src/docs/tex/ufo-manual_EN.pdf': No such file or directory
dh_install: cp -a ./src/docs/tex/ufo-manual_EN.pdf debian/ufoai//usr/share/doc/ufoai-data// returned exit code 1
make: *** [install-arch] Error 2
debuild: fatal error at line 1330:
couldn't exec fakeroot debian/rules:
make: *** [deb] Error 2
« Last Edit: January 19, 2012, 09:06:07 am by wizardelo »

Offline shag

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #13 on: January 19, 2012, 09:54:27 am »
Quote
on topic: i tried to make deb from latest git and i got error missing ufo manual.pdf :)
file i got is "ufo-manual_EN.tex"

Yeah I have seen that too. I went into src/docs/tex and ran pdflatex manually. That worked without problems, and also rebuilding the deb after that went through without problems..

so there's still a small glitch in either
a) the clean (as in that it used the pdf from manual pdflatex run)
b) the build (somehow not building the pdf, or getting into an error running pdflatex, possibly due to sanitized PATH by debuild)

Offline shag

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #14 on: January 19, 2012, 10:37:41 am »
Ah found it. Preparing a patch now. I will submit to sourceforge as soon as I check the build completes successfully