UFO:Alien Invasion

Technical support => Linux => Topic started by: Mattn on October 16, 2011, 04:03:28 pm

Title: Debian/Ubuntu packages for i386/amd64
Post by: Mattn on October 16, 2011, 04:03:28 pm
I've uploaded i386 and amd64 debian squeeze packages (should also work on ubuntu) to the snapshots dir (http://ufoai.ninex.info/snapshots/)

Feedback is needed on these packages. Are they working at all on your system? If not, please attach your ufoconsole.log (~/.ufoai/2.4-dev/base) here. We would like to release deb packages with the 2.4 version.

amd64 (http://ufoai.ninex.info/snapshots/ufoai_2.4-dev_amd64.deb)
i386 (http://ufoai.ninex.info/snapshots/ufoai_2.4-dev_i386.deb)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Mattn on October 28, 2011, 08:32:47 pm
i've updated the packages and fixed some font bugs of the old ones - please try them and report problems.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: wizardelo on November 08, 2011, 04:28:12 pm
i've updated the packages and fixed some font bugs of the old ones - please try them and report problems.

i did try the 64.deb version on my Ubuntu 11.10 and i got stuck on binutils


$ sudo dpkg -i ufoai_2.4-dev_amd64.deb
Selecting previously deselected package ufoai.
(Reading database ... 341838 files and directories currently installed.)
Unpacking ufoai (from ufoai_2.4-dev_amd64.deb) ...
dpkg: dependency problems prevent configuration of ufoai:
 ufoai depends on binutils (<< 2.20.2); however:
  Version of binutils on system is 2.21.53.20110810-0ubuntu5.
dpkg: error processing ufoai (--install):
 dependency problems - leaving unconfigured


uname -a
Linux 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

EDIT: i did try to fake it with a symbolic link but it didnt work:) i got same error
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Davren13 on November 13, 2011, 01:34:38 am
I also tried the amd64 deb on Ubuntu 11.10 x64 and got stuck on binutils

$ sudo dpkg -i ufoai_2.4-dev_amd64.deb
Selecting previously deselected package ufoai.
(Reading database ... 147760 files and directories currently installed.)
Unpacking ufoai (from ufoai_2.4-dev_amd64.deb) ...
dpkg: dependency problems prevent configuration of ufoai:
 ufoai depends on binutils (<< 2.20.2); however:
  Version of binutils on system is 2.21.53.20110810-0ubuntu5.
dpkg: error processing ufoai (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Errors were encountered while processing:
 ufoai


uname -a
Linux requiem 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: wizardelo on December 13, 2011, 12:03:36 pm
any updates?
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: shag on January 17, 2012, 05:12:49 pm
Works mostly fine on my oneiric amd64 laptop w. intel graphics.

1) I had to force install with dpkg --force-depends though, and symlink /usr/lib/libbfd-2.20.1-system.20100303.so to /usr/lib/libbfd-2.21.53-system.20110810.so
2) In ~30 hours of playing I have seen 1 crash in the earth view, and 1 crash in the tactical mode

I am now building ubuntu oneiric packages from recent git. Will post links here when I confirm working game client.

Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: wizardelo on January 18, 2012, 08:33:53 am
Works mostly fine on my oneiric amd64 laptop w. intel graphics.

1) I had to force install with dpkg --force-depends though, and symlink /usr/lib/libbfd-2.20.1-system.20100303.so to /usr/lib/libbfd-2.21.53-system.20110810.so
2) In ~30 hours of playing I have seen 1 crash in the earth view, and 1 crash in the tactical mode

I am now building ubuntu oneiric packages from recent git. Will post links here when I confirm working game client.

I managed to build up a git version also but before december update, if ya can make .deb , i would apreciate it. tnx
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: shag on January 18, 2012, 02:12:53 pm
AMD64 oneiric packages of 2.4-dev are here :

http://www.outrightsolutions.nl/~sander/ubuntu/ufoai/ (http://www.outrightsolutions.nl/~sander/ubuntu/ufoai/)

Built from git from 2012-01-17

I had to make one adjustment to my ~/.ufoai/.../config.cfg, which was created by the existing debian 2.4-dev deb. I had to set ui_hunksize to 4 (from 2). I don't know if these new packages create the right default if config.cfg does not exist, haven't tested that yet..

Have fun!

Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on January 18, 2012, 02:17:15 pm
Hey shag :)

Welcome to the forums !

Cool, that you are using the "Oneiric Oncelot" already  8)

Edit: I mixed up "Oneiric Oncelot" and "Precise Pangolin" ;)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on January 18, 2012, 02:20:46 pm
btw, ui_hunksize has already been removed and changed to dynamic memory allocation AFAIK, so this should not be needed anymore:

http://ufoai.git.sourceforge.net/git/gitweb.cgi?p=ufoai/ufoai;a=commit;h=57a697251a85f966fbf32b0068eefc9b5004ecfe
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: shag on January 18, 2012, 02:23:54 pm
Hi! :)

Strange.. after installing the deb and running the game it exited with an error about ui_hunksize being too small.. maybe if the var is defined it still uses it and does checks on it..
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on January 18, 2012, 02:35:24 pm
Remove the ui_hunksize definition from the config.cfg file in .ufoai/base.
Also remove keys.cfg so it will be rewritten by the game, because there have been changes to this file as well...

The game does not do that automatically so probably there are remains left from your previous installation there...
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: wizardelo on January 19, 2012, 08:16:45 am
i had same problem, so i moved .ufoai folder somewhere else and it created new keys and config files and worked no problem.

on topic: i tried to make deb from latest git and i got error missing ufo manual.pdf :)
file i got is "ufo-manual_EN.tex"

Code: [Select]

cp: cannot stat `./src/docs/tex/ufo-manual_EN.pdf': No such file or directory
dh_install: cp -a ./src/docs/tex/ufo-manual_EN.pdf debian/ufoai//usr/share/doc/ufoai-data// returned exit code 1
make: *** [install-arch] Error 2
debuild: fatal error at line 1330:
couldn't exec fakeroot debian/rules:
make: *** [deb] Error 2
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: shag on January 19, 2012, 09:54:27 am
Quote
on topic: i tried to make deb from latest git and i got error missing ufo manual.pdf :)
file i got is "ufo-manual_EN.tex"

Yeah I have seen that too. I went into src/docs/tex and ran pdflatex manually. That worked without problems, and also rebuilding the deb after that went through without problems..

so there's still a small glitch in either
a) the clean (as in that it used the pdf from manual pdflatex run)
b) the build (somehow not building the pdf, or getting into an error running pdflatex, possibly due to sanitized PATH by debuild)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: shag on January 19, 2012, 10:37:41 am
Ah found it. Preparing a patch now. I will submit to sourceforge as soon as I check the build completes successfully
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: shag on January 19, 2012, 10:58:38 am
patch is here, although from my experience with my prev patches it will be in git within the next hour :)

https://sourceforge.net/tracker/?func=detail&aid=3475976&group_id=157793&atid=805244 (https://sourceforge.net/tracker/?func=detail&aid=3475976&group_id=157793&atid=805244)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: krytek on March 20, 2012, 12:50:52 am
Hey guys, first post here.
2.4 is amazing so far, thanks guys. Although there is still the resolution change bug from 2.3 (game crashes on start after res change)
a restart after res change solves the problem.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on March 20, 2012, 06:21:20 pm
Hey guys, first post here.
2.4 is amazing so far, thanks guys. Although there is still the resolution change bug from 2.3 (game crashes on start after res change)
a restart after res change solves the problem.
:o
Probably you did not play latest version of 2.4 as actual master version (& v2.4 branch) force you to restart the game when changing resolution, so the crash is avoided in all cases.
Please retry with a newer version (or wait a few weeks until v2.4 is finally released).
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: krytek on March 20, 2012, 10:16:48 pm
:o
Probably you did not play latest version of 2.4 as actual master version (& v2.4 branch) force you to restart the game when changing resolution, so the crash is avoided in all cases.
Please retry with a newer version (or wait a few weeks until v2.4 is finally released).
The version I got is from March 10th (IIRC)
Just to make sure we're on the same page, when I said "restart" I mean the PC, not the game.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on April 01, 2012, 01:34:03 am
You can find fresh .deb packages of our v2.4 Release Candidate for x86 (i386) and x86_64 (amd64) on the download page:

http://ufoai.org/wiki/index.php/Download
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: ferralll on April 02, 2012, 09:06:05 pm
I downloaded, but I got this message from the package installer.
Code: [Select]
Error: Dependency is not satisfiable: libjpeg62 (>= 6b1)
Does that mean that libjpeg62 is to high of a version? Or is there something else wrong?



EDIT:
I am running Ubuntu 10.04
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on April 02, 2012, 11:06:06 pm
I downloaded, but I got this message from the package installer.
Code: [Select]
Error: Dependency is not satisfiable: libjpeg62 (>= 6b1)
Does that mean that libjpeg62 is to high of a version? Or is there something else wrong?



EDIT:
I am running Ubuntu 10.04

This means you need a version of libjpeg62 that is bigger or same like 6b1.
You should be able to find a bigger version in the standard Ubuntu 10.04 repos: https://launchpad.net/ubuntu/lucid/amd64/libjpeg62
Try to install libjpeg62 via package manager.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: ferralll on April 02, 2012, 11:44:04 pm
Hmm...

Nope.  I checked, and I have libjpeg62 installed.  And I still get the same message. 

I tried re-installing it, and I tried restarting it.  But it is still giving the same message.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on April 03, 2012, 12:37:47 am
Hmm...

I have created a bug report and assigned it to our volunteer package creator accumulator.
I hope he can help soonish.

https://sourceforge.net/tracker/?func=detail&aid=3514277&group_id=157793&atid=805242

Edit: Seems accumulator moved it to feature requests ?! : http://sourceforge.net/tracker/?func=detail&aid=3514277&group_id=157793&atid=805245

Nevermind, according to this statement new packages have already been uploaded:
http://colabti.org/irclogger/irclogger_log/ufoai?date=2012-04-05#l18

Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: ferralll on April 06, 2012, 12:32:52 am
Seems like the new build is working.  I am installing it now.  (The libjpeg62 conflict did not re-occur)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on April 06, 2012, 12:35:34 am
Good news :)

Now, please also tell us that it starts, runs and plays better than ever before as well ;)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: ferralll on April 06, 2012, 01:09:38 am
Thanks for all the help MCR and Accumulator

I started it up, and it seems to run fine.  It is a bit slower than 3.2, but then again, I have a slow computer.  I just need to adjust some of the graphics profiles, and re-tool a couple of the keyboard controls.  (The battle map movement is difficult because of the slowness, but I will change that soon.)

But I fooled around with the Geoscape, and did a quick battle, and so far I think it is looking like a great improvement!

I will post if I have any problems.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: wizardelo on April 11, 2012, 08:40:12 am
installed the latest deb and no dependency problems or other errors occurred. so far it works fine. will post if i find anything that is out of place.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: MCR on April 11, 2012, 02:11:59 pm
installed the latest deb and no dependency problems or other errors occurred. so far it works fine. will post if i find anything that is out of place.

Good News :)
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Duque Atreides on October 15, 2012, 02:51:31 am
Hi! I was trying to install the i386 package on debian tablet. It uses Whezzy. I donīt know if the debian package that is on this page works on it. I used the installer but, it show me some errors. The "errors" are missing address. I belive that these are the address where the information is. I have full internet signal.

What can i do? Iīm not a linux user, but my tablet comes with whezzy.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: leadjester on October 22, 2012, 03:51:36 am
I am having boot issues as well, it crashes mid load.


Code: [Select]
2012/10/21 21:43:19
----- network initialization -------
2012/10/21 21:43:19 libcurl/7.27.0 OpenSSL/1.0.1c zlib/1.2.7 libidn/1.25 librtmp/2.3 initialized.
2012/10/21 21:43:19
------ server initialization -------
2012/10/21 21:43:19 added 8 maps to the mapcycle
2012/10/21 21:43:19
----- console initialization -------
2012/10/21 21:43:19 Console initialized.
2012/10/21 21:43:19
------- video initialization -------
2012/10/21 21:43:19 SDL version: 1.2.14
2012/10/21 21:43:19 I: desktop depth: 32bpp
2012/10/21 21:43:19 I: video memory: 0
2012/10/21 21:43:19 I: Available resolutions: 1280x1024 1280x960 1280x800 1280x768 1152x864 1024x768 1024x576 848x480 832x624 800x600 720x400 640x480 (12)
2012/10/21 21:43:19 I: video driver: x11
2012/10/21 21:43:19 I: setting mode -1
2012/10/21 21:43:19 I: set multisample buffers to 0
2012/10/21 21:43:19 I: set swap control to 0
2012/10/21 21:43:20 I: 1024x768 (fullscreen: yes)
2012/10/21 21:43:20 I: got 8 bits of stencil
2012/10/21 21:43:20 I: got 24 bits of depth buffer
2012/10/21 21:43:20 I: got double buffer
2012/10/21 21:43:20 I: got 8 bits for red
2012/10/21 21:43:20 I: got 8 bits for green
2012/10/21 21:43:20 I: got 8 bits for blue
2012/10/21 21:43:20 I: got 0 bits for alpha
2012/10/21 21:43:20 I: got 0 multisample buffers
GL_VENDOR: Intel Open Source Technology Center2012/10/21 21:43:20
GL_RENDERER: Mesa DRI Intel(R) IGD x86/MMX/SSE22012/10/21 21:43:20
GL_VERSION: 1.4 Mesa 9.02012/10/21 21:43:20
GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_3DFX_texture_compression_FXT1 GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_NV_vertex_program GL_ARB_depth_texture GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_vertex_program1_1 GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_ARB_half_float_pixel GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_pixel_buffer_object GL_ARB_texture_rectangle GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_rectangle GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_gpu_program_parameters GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_map_buffer_range GL_EXT_separate_shader_objects GL_ARB_ES2_compatibility GL_ARB_debug_output GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_ARB_texture_rgb10_a2ui GL_EXT_provoking_vertex GL_ARB_robustness GL_ARB_texture_storage GL_ARB_invalidate_subdata 2012/10/21 21:43:20
2012/10/21 21:43:20 Activate texture compression for Intel chips - see cvar r_intel_hack
2012/10/21 21:43:20 Disabling shaders for Intel chips - see cvar r_intel_hack
2012/10/21 21:43:20 Set max. texture resolution to 1024 - see cvar r_intel_hack
2012/10/21 21:43:20 found GL_ARB_multitexture
2012/10/21 21:43:20 found GL_ARB_texture_compression
2012/10/21 21:43:20 using GL_ARB_texture_compression
2012/10/21 21:43:20 found GL_ARB_texture_non_power_of_two
2012/10/21 21:43:20 using GL_ARB_texture_non_power_of_two
2012/10/21 21:43:20 found GL_EXT_texture_filter_anisotropic
2012/10/21 21:43:20 found GL_EXT_texture_lod_bias
2012/10/21 21:43:20 found GL_ARB_vertex_buffer_object
2012/10/21 21:43:20 using GL_ARB_vertex_buffer_object
max vertex buffer size: 3000
2012/10/21 21:43:20 found GL_ARB_fragment_shader
2012/10/21 21:43:20 found GL_ARB_shading_language_100
2012/10/21 21:43:20 GLSL version guaranteed to be supported by OpenGL implementation postfixed by vender supplied info: 1.20
2012/10/21 21:43:20 found GL_###_framebuffer_object
2012/10/21 21:43:20 using GL_ARB_framebuffer_object
2012/10/21 21:43:20 max draw buffers: 1
2012/10/21 21:43:20 max render buffer size: 2048
2012/10/21 21:43:20 max color attachments: 8
2012/10/21 21:43:20 Invalid value for cvar r_postprocess
2012/10/21 21:43:20 max supported vertex texture units: 16
2012/10/21 21:43:20 max supported lights: 8
2012/10/21 21:43:20 max texture units: 8
2012/10/21 21:43:20 max texture coords: 8
2012/10/21 21:43:20 max vertex attributes: 16
2012/10/21 21:43:20 max varying floats: 32
2012/10/21 21:43:20 max fragment uniform components: 16384
2012/10/21 21:43:20 max vertex uniform components: 16384
2012/10/21 21:43:20 max texture size: detected 2048
2012/10/21 21:43:20 ...but using 1024 as requested
2012/10/21 21:43:20 Using low resolution globe textures as requested.
2012/10/21 21:43:25 SDL_ttf version 2.0.9 - we need at least 2.0.7
2012/10/21 21:43:25 Modified render related cvars
2012/10/21 21:43:25 glsl shutdown
2012/10/21 21:43:25
------- sound initialization -------
2012/10/21 21:43:25 SDL_mixer version: 1.2.8
2012/10/21 21:43:25 ... requested audio rate: 44100
2012/10/21 21:43:25 ... driver: 'pulse'
2012/10/21 21:43:25 ... audio rate: 44100
2012/10/21 21:43:25 ... audio channels: 2
2012/10/21 21:43:25
------- input initialization -------
2012/10/21 21:43:25 0 possible joysticks
2012/10/21 21:43:25 no joystick found.
2012/10/21 21:43:25 Allocate 3 megabytes for the ui hunk
2012/10/21 21:43:25
----------- parse scripts ----------
2012/10/21 21:43:25 56 script files
2012/10/21 21:43:26 ...  0: extension
2012/10/21 21:43:26 ...  1: headgear
2012/10/21 21:43:26 ...  2: right
2012/10/21 21:43:26 ...  3: left
2012/10/21 21:43:26 ...  4: backpack
2012/10/21 21:43:26 ...  5: belt
2012/10/21 21:43:26 ...  6: holster
2012/10/21 21:43:26 ...  7: armour
2012/10/21 21:43:26 ...  8: floor
2012/10/21 21:43:26 ...  9: equip
2012/10/21 21:43:27 53 ui script files
2012/10/21 21:43:33 Shared Client/Server Info loaded
2012/10/21 21:43:33 ...108 items parsed
2012/10/21 21:43:33 ... 31 damage types parsed
2012/10/21 21:43:33 ... 32 equipment definitions parsed
2012/10/21 21:43:33 ... 10 inventory definitions parsed
2012/10/21 21:43:33 ... 22 team definitions parsed
2012/10/21 21:43:33 executing keys.cfg
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: hudinv.bt_exit (i)
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: hud_alt.showinventory (i)
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: hud_mini.showinventory (i)
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: ahudinv.hideinventory (i)
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: hud_nohud.showinventory (i)
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: radarwindow.closeradar (HOME)
2012/10/21 21:43:33 Warning: Empty description for UI keybinding: radarwindow.closeradar (h)
2012/10/21 21:43:33 UI_SetKeyBinding: node "sequence.next" not found.
2012/10/21 21:43:33 music change to van_theme (from PsymongN3)[/li]
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: SharkD on November 23, 2012, 03:00:52 am
Could you create a torrent to the files? Thanks!
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: jhaand on December 22, 2012, 09:51:07 am
It took a while, before I could find the snapshot dir. Putting a link to the snapshots on the download page would also help a lot.
http://ufoai.org/snapshots/

Unfortunately I can't access them using FTP, but it will have to do.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Battlescared on February 18, 2013, 12:30:53 am
Just an FYI.  2.4 will run in Mint 14-64 bit from source after installing a number of dev packages.  Seems to be running great.  Have not messed with 2.5 dev, but will certainly when 2.6 (or whatever is the next official baseline) is released.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: jattra on March 13, 2013, 11:11:18 am
Hello,
I have tried the 64bit version and it does not work well for me (same as 2.3 release).
I am running PC with intel board and i5 processor with intel HD4000, Ubuntu 12.04.

The game starts but the graphic is broken, almost unreadable. See screanshot.

I don't see anything wrong in log file. Thanks for any help.

******
EDIT
I have found the solution (or workaround?). I have uninstalled libtxc-dxtn-s2tc0 and textures are fine now... 
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Sandro on March 13, 2013, 05:29:13 pm
Broken texture compression. UFO:AI automatically enables texture compression on Intel video hardware, and relies on driver to do it. Guess, that library got some problem understanding the UFO:AI (it uses RGBA format even for non-RGBA textures).
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Mattn on November 25, 2015, 10:48:45 pm
ufoai is now awaiting approval for getting into debian. it's packaged and uploaded to their ftp servers. this process might take some days or weeks - but hopefully we will have it debian then.
Title: Re: Debian/Ubuntu packages for i386/amd64
Post by: Tchey on December 11, 2015, 07:29:58 pm
Hello,

What's the best way to play 2.6 on my system ? I tried to follow "how to compile it yourself" something, but i got lost in the way, and the installer is only for Windows systems. I don't feel i want to play 2.5

Should i just wait ?

Thanks

Linux Mint 17.2 64 bits Xfce
Intel Core i5 4590 (4 x 3,3 GHz)
MSI GeForce GTX 960 @ 2 Go
8 Go DIMM DDR3 PC12800
LCD 1920x1080
French system, AZERTY keyboard