project-navigation
Personal tools

Author Topic: Errors  (Read 9560 times)

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: Errors
« Reply #30 on: February 23, 2009, 12:59:44 am »
I use the installers....maybe I installed over an old version and it didnt replace....

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Errors
« Reply #31 on: February 23, 2009, 02:22:21 pm »
or the package is broken...

-geever

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Errors
« Reply #32 on: February 23, 2009, 02:58:14 pm »
I'm working on building a new installer today, but it will take a few hours to fully compile and upload it to FileFront.

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: Errors
« Reply #33 on: February 23, 2009, 10:36:56 pm »
Geever: When I deleted the install folder and re-installed, it worked fine (Save for the occasional crash witho no error or mesage in console log)

EDIT: Yeah, I notice that when I have lag, and I check the console, it says that things are out of sync. This is after re-instal (r22773)
« Last Edit: February 24, 2009, 03:18:10 am by vedrit »

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: Errors
« Reply #34 on: February 25, 2009, 01:28:09 am »
Got an error when trying to equip. r22948


Assertion Failed!

File: (Edited out)\src\client\renderer\r.state.c
Line 58

Expression: texnum > 0

odie

  • Guest
Re: Errors
« Reply #35 on: February 25, 2009, 03:07:08 am »
I use the installers....maybe I installed over an old version and it didnt replace....

Hi vedrit,

sorry for not replying this earlier. I saw this but was working on getting some things from previous versions trashed out.

Pertaining to your usage of installers.....

1) You will need to know that clean uninstallation needs to be done for every update to be effective. What i meant by this is:

a. Uninstall the old version - Goto control panel, "add and remove programs", select UFO 2.3 dev, uninstall. you may wish to try uninstalling only the data and keep the save games..... though on some occassions they do break.

b. And if u r beta testing, you might wish to track what has been changed and if its a major bug squashed or something u have feedback is solved. in this case, u will probably want to start afresh anyway and hence, might as well remove the save files.

c. Goto the directory u have installed the old version. Delete the directory manually, NSIS-compiled scripts usually do not remove it, and new installers usually picks the empty directory up and give some.... well.... not-for-concern warning. Removing the directory will prevent that warning.

2) If you are on WinXP or Vista (which i assume u r), a restart is not necessary. Do not know abt Mac and Linux (though i believe they do not need too either). Simply install the downloaded installer and bingo, u have the files in.

Hope this help.

PS: Regarding your rendering failure -> Curious what your graphics card is (hardware) and the version of the drivers installed......

You may find out from the hardware, System on Control Panel.
This might help the folks here to see and share their experience. :)

odie

  • Guest
Re: Errors
« Reply #36 on: February 25, 2009, 03:20:11 am »
And oh,

I thought these links might help as to find out whats being bugged and squashed.
Bugs Report Page for UFOAI Project
New Bug Tracker

And also this:
Bug Tracker Help
UFOAI Project Homepage

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: Errors
« Reply #37 on: February 25, 2009, 05:56:32 am »
NVidia GeForce 8200, though it was old drivers. A new one was released the 18th of Feb.

odie

  • Guest
Re: Errors
« Reply #38 on: February 25, 2009, 07:19:29 am »
NVidia GeForce 8200, though it was old drivers. A new one was released the 18th of Feb.

Nods.

You might want to do an auto check and update if u r not so tech savy for ur Nvidia drivers at:
Drivers Auto Update

You might want to take note that u need to enable java AND pop ups for this page.

If you know and want to select manually the drivers, goto:
List of Products

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Errors
« Reply #39 on: February 25, 2009, 09:48:24 am »
Got an error when trying to equip. r22948

Assertion Failed!

File: (Edited out)\src\client\renderer\r.state.c
Line 58

Expression: texnum > 0

Your bug is  this.

-geever

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: Errors
« Reply #40 on: March 02, 2009, 01:14:43 am »
Was setting saved firing AP on a mission with grenade launcher and I got this

Mem_Free: bad memory header top sentinel [buffer underflow]
free: V:\MinGW\ufoai\src\common\common.c:#1400

on r23205