project-navigation
Personal tools

Author Topic: UFO Crash at lauch (2.2 branch - rev 13597 - 2007-12-16)  (Read 6535 times)

Razorix 22

  • Guest
UFO Crash at lauch (2.2 branch - rev 13597 - 2007-12-16)
« on: December 16, 2007, 09:53:28 pm »
Hello people.

As you can show it, the "2.2 branch - rev 13498 - 2007-12-12" version of UFO : AI crash me when I launch it. The console appear with the window of the game, but there is nothing in these window.

And a few moments later, the console and the empty window left the screen.

I've got this on the console :

Code: [Select]
----- network initialization -------
libcurl/7.16.4 zlib/1.2.2 initialized.

------ server initialization -------

----- console initialization -------
couldn't load history
Console initialized.

------- video initialization -------
SDL version: 1.2.11
I: desktop depth: 32bpp
I: setting mode 6: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
GL_VENDOR: Intel
GL_RENDERER: Intel 915GM
GL_VERSION: 1.4.0 - Build 4.14.10.4363
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_cull_vertex GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_filter_anisotropic GL_EXT_texture3D GL_3DFX_texture_compression_FXT1 GL_IBM_texture_mirrored_repeat GL_NV_blend_square GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_WIN_swap_hint
Activate texture compression for Intel chips
ignoring GL_EXT_LockArrays
using GL_ARB_multitexture
using GL_EXT_texture_env_combine
GL_SGIS_multitexture not found
using GL_ARB_texture_compression
using GL_EXT_texture_filter_anisotropic [ 4 max] [ 1 selected]
GL_EXT_texture_lod_bias not found
using GL_EXT_stencil_wrap
using GL_EXT_fog_coord
using GL_ARB_fragment_program
GL_ARB_shading_language_100 not found
GL_ATI_separate_stencil not found
using GL_EXT_stencil_two_side
max texture size: detected 2048
SDL_ttf version 2.0.7 - we need at least 2.0.7

------- sound initialization -------
SDL_mixer version: 1.2.8
...audio rate: 44100
...audio channels: 2
...driver: 'dsound'

------- video initialization -------
SDL version: 1.2.11
I: desktop depth: 32bpp
I: setting mode 6: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
GL_VENDOR: Intel
GL_RENDERER: Intel 915GM
GL_VERSION: 1.4.0 - Build 4.14.10.4363
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_cull_vertex GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_filter_anisotropic GL_EXT_texture3D GL_3DFX_texture_compression_FXT1 GL_IBM_texture_mirrored_repeat GL_NV_blend_square GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_WIN_swap_hint
Activate texture compression for Intel chips
ignoring GL_EXT_LockArrays
using GL_ARB_multitexture
using GL_EXT_texture_env_combine
GL_SGIS_multitexture not found
using GL_ARB_texture_compression
using GL_EXT_texture_filter_anisotropic [ 4 max] [ 1 selected]
GL_EXT_texture_lod_bias not found
using GL_EXT_stencil_wrap
using GL_EXT_fog_coord
using GL_ARB_fragment_program
GL_ARB_shading_language_100 not found
GL_ATI_separate_stencil not found
using GL_EXT_stencil_two_side
max texture size: detected 2048
SDL_ttf version 2.0.7 - we need at least 2.0.7
...registering 0 fonts
Could not set mission aircraft

I use Windows XP SP2, with an intel chipset as graphic card.

PS : I'm sorry for my poor english :/
« Last Edit: December 17, 2007, 05:48:15 pm by Razorix 22 »

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #1 on: December 16, 2007, 10:07:50 pm »
isnt't your version from 2007/12/16? please verify (see main menu - lower left)

try to start with ufo.exe +set r_intel_hack 0

Razorix 22

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #2 on: December 16, 2007, 10:13:58 pm »
I download it today, but didn't think that was a new version. ^^' The date version on the site was noticed as the 12/12 ^^'

The game start with these command, but its very laggy and the geoscape seems to have a little graphic bug : http://z1.zod.fr/z/sans-titre-1-jij.jpg

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #3 on: December 16, 2007, 10:17:15 pm »
i've just uploaded a new version today

go to options menu and activate texture compression

Razorix 22

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #4 on: December 16, 2007, 10:28:46 pm »
Ok.

I change the configuration so, its a lot better thanks. I don't have anymore the geoscape bug.

I shall test this so, thanks again. :)

EDIT : Hmmmm, It seems that all textures disappeared :/ I don't have any view of equipment, soldiers, ships (on battle and on the geoscape) : http://z1.zod.fr/z/sans-titre-2-pij.jpg

I changed my configuration a lot of times, it's all time the same problem. :/

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #5 on: December 17, 2007, 12:31:39 am »
but you had them before?

Razorix 22

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #6 on: December 17, 2007, 07:16:58 am »
No, I don't think so :/

I have the texture on the 2.1.1 version, but I have never seen any one in these one.

tiamatloc

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #7 on: December 17, 2007, 12:36:59 pm »
I think this is similar to what i encountered with newer versions, the geoscope is the same but i didn't get missing textures in the combat view. Try going into the video options and setting the texture resolution cap to a lower value, then restart UFO. I can't set it higher than "Normal" anymore but was fine with the highest settings on 2.1.1 (and earlier beta builds too).

@Mattn - I spotted this as i came back to update my topic. Since you put that hack in for the texture compression i get exactly the same console output as Razorix 22 does (ending in "...registering 0 fonts" and "Could not set mission aircraft") when trying to start UFO (both your original patch and the one that went into trunk). I had to comment out the whole check to get UFO to start.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #8 on: December 17, 2007, 01:31:59 pm »
this should already be fixed in current 2.2 branch, no?

Razorix 22

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #9 on: December 17, 2007, 03:40:22 pm »
I think this is similar to what i encountered with newer versions, the geoscope is the same but i didn't get missing textures in the combat view. Try going into the video options and setting the texture resolution cap to a lower value, then restart UFO. I can't set it higher than "Normal" anymore but was fine with the highest settings on 2.1.1 (and earlier beta builds too).

Changing video options and texture resolution don't make going back textures. :/
And it isn't only on the combat screen that textures are missing, but also on the soldiers screen, equipment screen, aircrafts screen, etc...

tiamatloc

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #10 on: December 17, 2007, 04:20:54 pm »
this should already be fixed in current 2.2 branch, no?

tlh2000's changes to r_main.c in R13601 trunk have fixed the crash on startup, the same fix has gone into branches/ufoai_2.2/ R13608 as well. I was on trunk R13600 at the time of posting so i didn't have the fix.

Comparing the console output to mine i notice i have a slightly newer GL_VERSION (1.3.0 - Build 4.14.10.4396), yet my Intel 865G chip is older. A newer driver is all i can think of. Sorry.

Razorix 22

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13498 - 2007-12-12)
« Reply #11 on: December 17, 2007, 04:43:33 pm »
I've looked updates for my chipset 3 weeks ago :/

I try to play on another computer, i've got the same problem. Crash at launch, and then, with the command "ufo.exe +set r_intel_hack 0", the game start, but I don't have any texture again. (Intel 82865G Graphics controller)

I looked again on the log of the console, and i saw this error : "No model given or not in md2 format"

it repeat a hundred of times... :/

Razorix 22

  • Guest
Re: UFO Crash at lauch (2.2 branch - rev 13597 - 2007-12-16)
« Reply #12 on: December 17, 2007, 06:16:57 pm »
Sorry for double posting, but I found where the problem come from...

The 0models.pk3 file is missing on the base folder.

Offline Rincewind

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: UFO Crash at lauch (2.2 branch - rev 13597 - 2007-12-16)
« Reply #13 on: December 18, 2007, 05:11:52 pm »
Yeah, I get the same problem as Razorix (missing models) when trying the latest precompiled dev version available at mattn.ninex. Seems like you forgot to include the models. :D Filesize is only some 330 megs while it says it should be 400+.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: UFO Crash at lauch (2.2 branch - rev 13597 - 2007-12-16)
« Reply #14 on: December 18, 2007, 06:31:56 pm »
i will upload a new one tomorrow

thanks for reporting