project-navigation
Personal tools

Author Topic: Awfully slow, full CPU usage  (Read 3724 times)

anton.pussep

  • Guest
Awfully slow, full CPU usage
« on: June 26, 2007, 11:14:21 pm »
I just compiled and installed the latest stable SVN version on my Debian 4.0. The compilation worked without any problems and I have nice .deb files now, many thanks for the great work! However, when I start the game it is awfully slow. It is hardly possible to move the mouse to a certain place in the main menu, not even mentioning the actual game...

I found out that the CPU usage rises to 100%. I suspected OpenGL being a problem, but glxinfo says that direct rendering is activated and glxgears runs almost without using the CPU at all. My chipset is a Intel mobile 915. I tested Debian stable with kernel 2.6.21.5 and Debian testing with kernel 2.6.18.8 with the very same effect. I configured everything according to http://www.larsen-b.com/Article/231.html and as I said, glxinfo output seems quite reasonable.

Any ideas what might be wrong?

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Awfully slow, full CPU usage
« Reply #1 on: June 26, 2007, 11:32:01 pm »
your intel chipset is the problem - see http://ufoai.ninex.info/wiki/index.php/Manual/System_Requirements

if you find a solution - please let us know

ibykus

  • Guest
i810 driver works for mee
« Reply #2 on: July 13, 2007, 09:51:37 am »
I am running ufo:ai on a IBM X41 with i810 video driver under debian. First I had the same problems. But by changing config.cfg I got rid of them. Change/add the following line to config.cfg:  set gl_ext_pointparameters "0".

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Awfully slow, full CPU usage
« Reply #3 on: July 13, 2007, 10:09:43 am »
that's good news - can you please send the vendor string of your intel card? or even better the hole ufoconsole.log (via pastebin maybe)

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Awfully slow, full CPU usage
« Reply #4 on: July 13, 2007, 11:10:35 am »
can you maybe try the latest revision in trunk? does that fix your intel card problems?

sparktherookie

  • Guest
Awfully slow, full CPU usage
« Reply #5 on: July 25, 2007, 04:44:04 pm »
Wohoo, confirmed!

ibykus's fix makes this stunning game (finally!) run flawlessly on my machine.

Here are the specs:

- I'm running Ubuntu 7.04 "Feisty Fawn"
- The UFO:AI version is mattn's beta installer release (rev 9457)
- The video chipset is a Intel 945GM

My ufoconsole.log:
Code: [Select]

Hostname: Andromeda
IP: 127.0.1.1
...using language: de_DE.UTF-8
Console initialized.

------- sound initialization -------
Loading snd_sdl sound driver
Could not load snd_sdl.so and snd_sdl_i386.so
Load library (snd_sdl) failed - no sound available
------- Loading ref_glx -------
Sys_LoadLibrary ("ref_glx")
ref_gl version: GL 0.12
LoadLibrary ("libGL.so.1")
Initializing OpenGL display
...setting fullscreen mode 6: 1024 768
...using XFree86-VidModeExtension Version 2.2
I: got 8 bits of stencil
I: got 8 bits of red
I: got 8 bits of blue
I: got 8 bits of green
I: got 24 bits of depth
I: got 8 bits of alpha
...using hardware gamma
GL_VENDOR: Tungsten Graphics, Inc
GL_RENDERER: Mesa DRI Intel(R) 945GM 20061017 x86/MMX/SSE2
GL_VERSION: 1.3 Mesa 6.5.2
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_cull_vertex GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_3DFX_texture_compression_FXT1 GL_APPLE_client_storage GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_NV_vertex_program1_1 GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SUN_multi_draw_arrays
...ignoring GL_EXT_LockArrays
...ignoring GL_EXT_point_parameters
...ignoring GL_ARB_multitexture
...using GL_EXT_texture_env_combine
...GL_SGIS_multitexture not found
...ignoring GL_ARB_texture_compression
...ignoring GL_EXT_texture_filter_anisotropic
...using GL_EXT_texture_lod_bias
...using GL_EXT_stencil_wrap
...using GL_EXT_fog_coord
...using GL_ARB_fragment_program
...GL_ARB_shading_language_100 not found
...GL_ATI_separate_stencil not found
...GL_EXT_stencil_two_side not found
...max texture size:
......detected 2048
......but using 256 as requested
...SDL_ttf version 2.0.8 - we need at least 2.0.7
...SDL_ttf inited
------------------------------------
CDAudio_Init: No CD in drive.
CDAudio_Init: CD contains no audio tracks.
CD Audio Initialized.
Init saving subsystems
...added size subsystem (check ff)
...added base subsystem (check 0)
...added campaign subsystem (check 1)
...added hospital subsystem (check 2)
...added market subsystem (check 3)
...added research subsystem (check 4)
...added employee subsystem (check 5)
...added aliencont subsystem (check 6)
...added production subsystem (check 7)
...added aircraft subsystem (check 8)
...added messagesystem subsystem (check 9)
...added stats subsystem (check a)
...added nations subsystem (check b)
libcurl/7.15.5 OpenSSL/0.9.8c zlib/1.2.3 libidn/0.6.5 initialized.
Shared Client/Server Info loaded
Cinematic videos/intro.roq not found
Unknown command "music_start"
MN_PrecacheModels: Could not register model 'models/aircraft/inter_stingray/stingray_landed.md3'
Com_PrecacheCharacterModels: Could not register model aliens/hovernet/head01
Com_PrecacheCharacterModels: Could not register model aliens/hovernet/head01
Mod_LoadTags: found 84 frames in models/aliens/bloodspider/bloodspider.tag but model has 198 frames
Com_PrecacheCharacterModels: Could not register model soldiers/ugv_triax/triax
...precaching 72 menus
====== UFO Initialized ======

Save user settings to /home/sparktherookie/.ufoai/2.2-dev/base/config.cfg

anttix

  • Guest
Awfully slow, full CPU usage
« Reply #6 on: July 25, 2007, 05:57:15 pm »
Got IBM T60.
Intel Mobile 945GM
Fedora Core 6

With 2.1 FPS is about 6
With latest SVN version FPS jumped to 93
Game works well now.
Great work!

marvin8

  • Guest
Awfully slow, full CPU usage
« Reply #7 on: July 28, 2007, 12:43:44 pm »
The new SVN version did the trick for me too.
Thinkpad X60
Intel Mobile 945GM
Ubuntu Breezy Badger

Thanks!