project-navigation
Personal tools

Author Topic: unable to play newest svn with linux  (Read 3851 times)

Ossi

  • Guest
unable to play newest svn with linux
« on: June 12, 2006, 08:03:24 pm »
Hi,
I'm new on this game... just found it, tried the 0.12 package (worked fine!) and now I want to play 0.13 compiled from source (research working.. equipment and so on). Therefore I downloaded from svn and compilation worked well so far...
Then I've linked binaries into base-dir (from src/debugi386) and started the game. Two revisions before (now I have 1402 I think) everything worked nearly perfect but with the recent svn my saves don't load anymore; the saved game starts with a green or red screen and hags when klicking somewhere.

last console output of this game is not very useful:
------------------------------------
CDAudio_Init: Unable to open default CD-ROM drive: Invalid CD-ROM drive index
couldn't exec autoexec.cfg
...using language: de_DE.UTF-8
Shared Client/Server Info loaded
...precaching 46 menus
Can't find pics/
Can't find pics/menu/multi_buttons1
Can't find pics/menu/main_buttons2
Can't find pics/menu/button_connect_to_ip
====== UFO Initialized ======

Changing to Singleplayer
Savefile version 4 detected
CL_GameLoad: Campaign "main" doesn't exist.
Can't find pics/menu/_day
Can't find pics/menu/_night
--------------------------------------------------------------------

I think the problem is
>> CL_GameLoad: Campaign "main" doesn't exist.
because of this it is impossible to enter a new game too.

I don't know where the campaigns are located... or why they are not found.

but I think the problem is somewhere with my configuration..otherwise I should have found something similar in this forum.   :oops:

If someone have some suggestions...   :wink:


I've build revision 1419 today... don't solve the problem  :cry:

Offline Bandobras

  • Captain
  • *****
  • Posts: 586
    • View Profile
unable to play newest svn with linux
« Reply #1 on: June 15, 2006, 03:03:33 am »

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
unable to play newest svn with linux
« Reply #2 on: June 15, 2006, 08:18:35 am »
first make sure that you've deleted all savegames and saved teams - they are broken atm.

which revision is it?

Ossi

  • Guest
unable to play newest svn with linux
« Reply #3 on: June 15, 2006, 11:27:11 am »
Yes, I've also compiled the maps over night...  :lol:

and I've fixed it ..  it was tooo simple :roll:
The problem was that with the newer svn-version the directories where the game-bins are located has changed from trunk/src/debugi386 and trunk/src/releasei386 to trunk/debugi386 and trunk/releasei386. But my compile-script everytime linked the old binaries which coldn't handle the new stuff in base dir I think.

Now I have these probs with my savegames.. but thank's to Mattn I know why ^^. Hopefully they'll work in the next update.

Thank's for your help at all!  8)