UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #4944  -  error when setting worldspawn properties in .ump file
Posted Mar 25, 2013 - updated Mar 25, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "Not determined".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     mattn
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     shipit
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    1 hour
  • Category
    Map Compiler (ufo2map)
  • Resolution
    Not determined
  • Priority
    4. Useful
  • Reproducability
    Always
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Windows
  • Architecture
    icon_customdatatype.png Not determined
Issue description
I removed the settings from the .map files in +bridge and set them in the .ump file instead.

worldspawn {
	"maxteams" "2"
"maxlevel" "5"
"saturation" "0.6"
"brightness" "0.8"
}

When I try to compile I get one of the following errors.

use worldspawn settings from ump file
Error: Mem_Alloc: failed on allocation of '64' bytes
alloc: E:\buildUFOAI\codeblocks\msysgit\ufoai\src\tools\ufo2map\common\bspfile.cpp:#418


use worldspawn settings from ump file
Error: Mem_Alloc: failed on allocation of '64' bytes
alloc: E:\buildUFOAI\codeblocks\msysgit\ufoai\src\tools\ufo2map\map.cpp:#1016


Steps to reproduce this issue
Remove the comment marks around the worldspawn settings in bridge.ump and compile the maps.