UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #3470  -  battlescape crash, "could not add 1 item"
Posted Jan 18, 2013 - updated Aug 07, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     DarkRain
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     jkkurja
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    RESOLVED
  • Priority
    1. Very low
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 3470 imported from sourceforge.net tracker on 2013-01-28 20:10:24

crash from battlescape to geoscape

2013/01/16 22:34:33 Team 1 ended round 2013/01/16 22:34:33 Team 7's round started! 2013/01/16 22:34:33 STATS Szsfh Vzs Hzffs is bleeding (damage: 10) 2013/01/16 22:34:33 STATS Szsfh Vzs Hzffs is consumed by mad rage (entnum 66). 2013/01/16 22:34:35 STATS alien (Mrorg Or Hom Mohrm) kills civilian (b c) with Cannonade of needlergun_ammo (entnum: 58) 2013/01/16 22:34:40 Rita van de Wijdeven panics! 2013/01/16 22:34:40 STATS Rita van de Wijdeven is bleeding (damage: 3) 2013/01/16 22:34:40 STATS Hao Lami is bleeding (damage: 3) 2013/01/16 22:34:40 STATS Rita van de Wijdeven panics (entnum 78). 2013/01/16 22:34:40 ******************** 2013/01/16 22:34:40 ERROR: InvAdd failed - could not add 1 item(s) of fraggrenade to container 2 2013/01/16 22:34:40 ******************** 2013/01/16 22:34:42 Shutdown server: Server crashed. 2013/01/16 22:34:42 Unload the game library 2013/01/16 22:34:42 Disconnecting... 2013/01/16 22:34:42 Client stream was closed
Comments Ported from Sourceforge  ⇑ top
darkrainx (2013-01-18 19:51:56.025000)  ⇑ top
I've seen this with AI controlled soldiers, I was using g_aihumans at the time, but panic also causes the soldier to be controlled by the AI It happens when the AI controlled soldiers drop their weapon and try to pick a new one from their inventory. It is caused by bad event scheduling: the EV_INV_ADD event -that adds the item to the hand- is executed before the EV_INV_DEL -that should have removed the previous item from the hand-, the server actually sends the events in the correct order, but the client ends scheduling them the other way around.
darkrainx (2013-01-21 15:17:48.968000)  ⇑ top
Most likely connected with actor death - the EV_INV_ADD event has a different delay when parsed after an EV_ACTOR_DIE event
Steps to reproduce this issue
Nothing entered.