UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #3456  -  pathfinding does not recognize 'opened' flag for func_door correctly
Posted Jan 02, 2013 - updated Jun 11, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     aduke1
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     shipit
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    19 weeks, 4 hours
  • Category
    General
  • Resolution
    RESOLVED
  • Priority
    1. Very low
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 3456 imported from sourceforge.net tracker on 2013-01-28 20:10:24

In the attached map the func_door entity has the 'opened' flag set. Due to this it is not possible to move the actor down the hallway. The pathfinding information in Radiant shows a correct path.

On the other hand, if removing the opened flag, it is possible to move the actor trough the door.
Comments Ported from Sourceforge  ⇑ top
shipit (2013-01-02 10:32:38.158000)  ⇑ top
Attached screenshot: actor doesn´t move where he should.

The func_door has 'opened' flag set here.
shipit (2013-01-02 10:38:33.388000)  ⇑ top
Attached screenshot: actor moves where he should not.

The func_door has NOT set the 'opened' flage in this case.
shipit (2013-01-02 11:14:58.323000)  ⇑ top
- **summary**: pathfinding does not recognice 'opened' flag for func_door correctly --> pathfinding does not recognize 'opened' flag for func_door correctly
 
aduke1 (2013-01-13 03:18:58.490000)  ⇑ top
Confirmed. One of the problems seems to be that CM_GetInlineModelAABB doesn't take the changed angles into account.

Steps to reproduce this issue
Nothing entered.