UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #3415  -  Game doesn't pause on buiding built up if it is yet unusable
Posted Nov 08, 2012 - updated Mar 10, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     mattn
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     shipit
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Time spent
    1 hour
  • Category
    General
  • Resolution
    RESOLVED
  • Priority
    1. Very low
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 3415 imported from sourceforge.net tracker on 2013-01-28 20:10:24

I have all three checkboxes in 'message settings/installation construction/installation build finished' enabled. This works, as far as I can see, for all buildings, but not for Command Centre. If the Command Centre is finished, the message is shown and also the sound is played, but the game is not paused.
Comments Ported from Sourceforge  ⇑ top
geever (2012-11-08 19:29:03.835000)  ⇑ top
- **summary**: Game does not pause on Command Centre built --> Game doesn't pause on buiding built up if it is yet unusable
 
geever (2012-11-08 19:29:04.004000)  ⇑ top
"installation build finished" is for sam sites, ufo yards, etc.

The time is stopped if the built building in a base is useable, it does stop for Command Centre as well, probably you didn't have its prerequisite (Power Plant) built up yet.

The idea behind this behaviour was that if the building is not useable, the player cannot do anything with it yet either. I almost closed the ticket due to this, but realized, that since we can only build next to a built up building this case is valid and we should be able to stop on this event.

I'll need to add a "base building finished" category to the messageoptions.
Steps to reproduce this issue
Nothing entered.