UFO: Alien Invasion Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #3138  -  func_door problem with a stair
Posted Feb 08, 2012 - updated Mar 08, 2013
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     aduke1
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     shipit
  • Owned by
    Not owned by anyone
  • Estimated time
    Not estimated
  • Category
    General
  • Resolution
    RESOLVED
  • Priority
    3. Normal
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Complexity
    icon_customdatatype.png Not determined
  • Platform
    icon_customdatatype.png Not determined
  • Architecture
    icon_customdatatype.png Not determined
Issue description
Item 3138 imported from sourceforge.net tracker on 2013-01-28 20:02:17

I posted all information about this in the forum : http://ufoai.ninex.info/forum/index.php/topic,6451.0.html
Comments Ported from Sourceforge  ⇑ top
tlh2000 (2012-02-08 20:03:14)  ⇑ top
 
tlh2000 (2012-02-08 20:04:33)  ⇑ top
from forum

taken from mansion_poolhouse

If the actor walks down the stair he seems to fall through it and gets stuck. If I remove the door from the map everything is fine.

I had the same problem at an early stage of this map and also on mansion_main, wich I solved be moving the doors. From this experience to me it looks like this happens, if the actor is able to 'use' the door from there (from the place where he gets stuck).

This was first reported from 'accumulator' on irc using ubuntu/amd64/ufoai-git-master, opposed to my winXP.

I added the example .map file from the picture, taken out of mansion_poolhouse.map.
tlh2000 (2012-02-08 20:04:54)  ⇑ top
 
aduke1 (2012-10-07 01:35:22.870000)  ⇑ top
- **assigned_to**: Duke - **milestone**: --> 2.4

- **milestone**: 2.4 --> 2.5
 
aduke1 (2012-12-18 20:13:18.955000)  ⇑ top
The problem here is that the cell in question has *2* valid floors. Routing can not support that. I can not (yet) explain why and how the nearby door influences pathfinding. But that's a secondary problem. ShipIt, could you plz place a crate or similar under the stairs to block the lower floor and check if everything works as desired then ?
Steps to reproduce this issue
Nothing entered.