project-navigation
Personal tools

Author Topic: Error at the start of the game, missing files  (Read 1966 times)

Offline sometimesplay

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Error at the start of the game, missing files
« on: April 30, 2017, 10:15:55 am »
Hello and thank you for a great game!

I played 2.6-dev for some time, uninstalled it and now I am trying to install and play again. But something goes wrong. Here is the full log:

---- endianness initialization -----
found little endian system

---- filesystem initialization -----
Adding game dir: /usr/local/games/ufo//base
Adding game dir: ./base
Added packfile ./base/0base.pk3 (15 files)
Added packfile ./base/0maps.pk3 (899 files)
Added packfile ./base/0materials.pk3 (42 files)
Added packfile ./base/0media.pk3 (19 files)
Added packfile ./base/0models.pk3 (2814 files)
Added packfile ./base/0music.pk3 (64 files)
Added packfile ./base/0pics.pk3 (1042 files)
Added packfile ./base/0shaders.pk3 (37 files)
Added packfile ./base/0snd.pk3 (347 files)
Added packfile ./base/0textures.pk3 (2734 files)
Added packfile ./base/0ufos.pk3 (138 files)
Could not load './base/0videos.pk3'
Adding game dir: C:\Users\XXX\AppData\Roaming\UFOAI/2.6-dev/base
using C:\Users\XXX\AppData\Roaming\UFOAI/2.6-dev/base for writing
executing filesystem.cfg
executing default.cfg
couldn't execute config.cfg

----- network initialization -------
libcurl/7.31.0 OpenSSL/1.0.1e zlib/1.2.8 libidn/1.28 libssh2/1.4.3 initialized.

------ server initialization -------
added 12 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
I: SDL version: 2.0.0
I: found 1 display(s)
I: current desktop mode: 1280x1024@60Hz (SDL_PIXELFORMAT_RGB888)
I: video driver: windows
I: available driver: windows
I: available driver: dummy
I: driver: windows
I: setting mode -1
I: using the desktop resolution because vid_mode, vid_height and vid_width are set to -1 (1280x1024)
I: try to get display with 1280x1024
I: disable multisample buffers
I: set swap control to 0
I: 1280x1024 (fullscreen: yes)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 8 bits for alpha
I: got multisample disabled
I: got 0 multisample buffers
GL_VENDOR: Intel
GL_RENDERER: Intel(R) HD Graphics Family
GL_VERSION: 3.1.0 - Build 8.15.10.2509
GL_EXTENSIONS: GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_EXT_texture_swizzle GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_EXT_texture_snorm GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_draw_elements_base_vertex GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_compatibility GL_ARB_vertex_array_object
You might want to activate texture compression if you have visual artifacts.
Disabling shaders for Intel chips - see cvar r_intel_hack
Set max. texture resolution to 1024 - see cvar r_intel_hack
OpenGL version detected: 3.1
found GL_ARB_multitexture
found GL_ARB_texture_compression
found GL_ARB_texture_non_power_of_two
using GL_ARB_texture_non_power_of_two
found GL_EXT_texture_filter_anisotropic
found GL_EXT_texture_lod_bias
found GL_ARB_vertex_buffer_object
using GL_ARB_vertex_buffer_object
max vertex buffer size: 1200
found GL_ARB_fragment_shader
found GL_ARB_shading_language_100
GLSL version guaranteed to be supported by OpenGL implementation postfixed by vender supplied info: 1.40
found GL_###_framebuffer_object
using GL_ARB_framebuffer_object
max draw buffers: 8
max render buffer size: 4096
max color attachments: 8
found GL_###_draw_buffers
using GL_ARB_draw_buffers
max supported vertex texture units: 16
max supported lights: 8
max texture units: 8
max texture coords: 8
max vertex attributes: 16
max varying floats: 41
max fragment uniform components: 1024
max vertex uniform components: 512
max texture size: detected 8192
...but using 1024 as requested
Using low resolution globe textures as requested.
SDL_ttf version 2.0.12 - we need at least 2.0.7
Modified render related cvars
glsl shutdown

------- sound initialization -------
SDL_mixer version: 2.0.0
... requested audio rate: 44100
... available audio driver directsound
... available audio driver winmm
... available audio driver disk
... available audio driver dummy
... actual audio driver: directsound
... audio rate: 44100
... audio channels: 2
... loaded ogg vorbis support

------- input initialization -------
0 possible joysticks
no joystick found.
Allocate 3 megabytes for the ui hunk

------- web initialization ---------
... web access not yet configured

----------- parse scripts ----------
60 script files
60 ui script files
UI_ParseAndLoadLuaScript: _assets.ufo
UI_ParseAndLoadLuaScript: _assets_base.ufo
UI_ParseAndLoadLuaScript: _assets_hud.ufo
lua error: [string "_assets_hud.ufo"]:3: module 'ufox.lua' not found:
    no field package.preload['ufox.lua']
    no file '.\ufox\lua.lua'
    no file '!\lua\ufox\lua.lua'
    no file '!\lua\ufox\lua\init.lua'
    no file '!\ufox\lua.lua'
    no file '!\ufox\lua\init.lua'
    no file '.\ufox\lua.dll'
    no file '!\ufox\lua.dll'
    no file '!\loadall.dll'
    no file '.\ufox.dll'
    no file '!\ufox.dll'
    no file '!\loadall.dll'
UI_ParseNodeBody: Command name for confunc 'PlayerSquad.squad_custom_options.squad_custom_load_opts.teamsaveslotadd' already registered
UI_ParseNodeBody: Command name for confunc 'PlayerSquad.squad_custom_options.squad_custom_load_opts.teamsaveslotsclear' already registered
UI_ParseNodeBody: Command name for confunc 'PlayerSquad.squad_custom_options.squad_custom_loaded_opts.team_memberadd' already registered
UI_ParseNodeBody: Command name for confunc 'PlayerSquad.squad_custom_options.squad_custom_loaded_opts.team_membersclear' already registered
UI_ParseAndLoadLuaScript: campaign.ufo
lua error: [string "campaign.ufo"]:3: module 'ufox.lua' not found:
    no field package.preload['ufox.lua']
    no file '.\ufox\lua.lua'
    no file '!\lua\ufox\lua.lua'
    no file '!\lua\ufox\lua\init.lua'
    no file '!\ufox\lua.lua'
    no file '!\ufox\lua\init.lua'
    no file '.\ufox\lua.dll'
    no file '!\ufox\lua.dll'
    no file '!\loadall.dll'
    no file '.\ufox.dll'
    no file '!\ufox.dll'
    no file '!\loadall.dll'
UI_ParseAndLoadLuaScript: campaign_main.ufo
lua error: [string "campaign_main.ufo"]:3: module 'ufox.lua' not found:
    no field package.preload['ufox.lua']
    no file '.\ufox\lua.lua'
    no file '!\lua\ufox\lua.lua'
    no file '!\lua\ufox\lua\init.lua'
    no file '!\ufox\lua.lua'
    no file '!\ufox\lua\init.lua'
    no file '.\ufox\lua.dll'
    no file '!\ufox\lua.dll'
    no file '!\loadall.dll'
    no file '.\ufox.dll'
    no file '!\ufox.dll'
    no file '!\loadall.dll'
UI_ParseAndLoadLuaScript: cgame.ufo
UI_ParseAndLoadLuaScript: endgame.ufo
lua error: [string "endgame.ufo"]:3: module 'ufox.lua' not found:
    no field package.preload['ufox.lua']
    no file '.\ufox\lua.lua'
    no file '!\lua\ufox\lua.lua'
    no file '!\lua\ufox\lua\init.lua'
    no file '!\ufox\lua.lua'
    no file '!\ufox\lua\init.lua'
    no file '.\ufox\lua.dll'
    no file '!\ufox\lua.dll'
    no file '!\loadall.dll'
    no file '.\ufox.dll'
    no file '!\ufox.dll'
    no file '!\loadall.dll'
UI_ParseAndLoadLuaScript: hud_.ufo
lua error: [string "hud_.ufo"]:3: module 'ufox.lua' not found:
    no field package.preload['ufox.lua']
    no file '.\ufox\lua.lua'
    no file '!\lua\ufox\lua.lua'
    no file '!\lua\ufox\lua\init.lua'
    no file '!\ufox\lua.lua'
    no file '!\ufox\lua\init.lua'
    no file '.\ufox\lua.dll'
    no file '!\ufox\lua.dll'
    no file '!\loadall.dll'
    no file '.\ufox.dll'
    no file '!\ufox.dll'
    no file '!\loadall.dll'
UI_ParseAndLoadLuaScript: hud_default.ufo
lua error: [string "hud_default.ufo"]:3: module 'ufox.lua' not found:
    no field package.preload['ufox.lua']
    no file '.\ufox\lua.lua'
    no file '!\lua\ufox\lua.lua'
    no file '!\lua\ufox\lua\init.lua'
    no file '!\ufox\lua.lua'
    no file '!\ufox\lua\init.lua'
    no file '.\ufox\lua.dll'
    no file '!\ufox\lua.dll'
    no file '!\loadall.dll'
    no file '.\ufox.dll'
    no file '!\ufox.dll'
    no file '!\loadall.dll'

« Last Edit: April 30, 2017, 10:25:06 am by sometimesplay »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Error at the start of the game, missing files
« Reply #1 on: April 30, 2017, 11:48:11 am »
Sorry, that was my mistake. I renamed some files recently and the new extension was not picked up by the build scripts. Fixed it just now, the next nightly should be okay.

-geever
« Last Edit: April 30, 2017, 02:17:20 pm by geever »

Offline sometimesplay

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: Error at the start of the game, missing files
« Reply #2 on: April 30, 2017, 12:24:10 pm »
Thank you!  :)