project-navigation
Personal tools

Author Topic: Multiplayer is LITERALLY UNPLAYABLE  (Read 2607 times)

Offline Dariagan

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Multiplayer is LITERALLY UNPLAYABLE
« on: June 28, 2017, 03:05:58 pm »
UFO:AI version: 2.6-dev IA 32 Jun 13 2017 Win 32 DEBUG (that's what it says)

The systems specs don't matter since this is not a graphical or performance bug.

What the title says, just try to play at least 2 games (or even one) in a row without having a single crash. Anything you do, crash. Accidentally gas civilian? Crash. You spot someone using goggles? Crash. You go up one level when the game is loading? Crash. Map finished loading? Crash. You killed someone with a certain weapon? Crash. Whatever? Crash. Also if you manage to survive one game without it crashing, the team you spent like 15 minutes making probably corrupts itself for no reason at all and you have to make a new one. That's why I always backup the team file, but if this happens to you for the first time without you knowing this can happen, you are gonna be pretty pissed. I am sorry if i am being very aggressive in this report but multiplayer gets me on my nerves, I just wanted to play a normal 1vs1 match with my friend who loves UFO:AI as much as I do and whom I wanted to challenge to see who has better tactics in this game.

To reproduce the crashes, you can just try to play a multiplayer match and you'll get a crash, no matter what you do.
Maps we played: Village or village 2 i think, farm, and one static map with two houses one which has three floors or so and the other one just one and there's a van in between.
« Last Edit: June 28, 2017, 03:18:35 pm by Dariagan »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Multiplayer is LITERALLY UNPLAYABLE
« Reply #1 on: June 29, 2017, 12:16:16 am »
I am sorry if i am being very aggressive in this report but multiplayer gets me on my nerves

Yeah, it would have worthed if you waited and calmed down before reporting the issue, but I understand your frustration. I created tickets about problems that are visible from the log file:

* Bug#5665 - [MP] InvAdd failed to container 0
* Bug#5666 - [MP] Could not get LE at e_event_actormove.cpp:42
* Bug#5667 - [MP] Could not get LE at e_event_particleappear.cpp:61

@DarkRain, could you take a look?

Cheers,
-geever

Offline Dariagan

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Multiplayer is LITERALLY UNPLAYABLE
« Reply #2 on: June 29, 2017, 01:34:46 am »
Yeah, it would have worthed if you waited and calmed down before reporting the issue, but I understand your frustration. I created tickets about problems that are visible from the log file:

* Bug#5665 - [MP] InvAdd failed to container 0
* Bug#5666 - [MP] Could not get LE at e_event_actormove.cpp:42
* Bug#5667 - [MP] Could not get LE at e_event_particleappear.cpp:61

@DarkRain, could you take a look?

Cheers,
-geever

Many thanks! And again, sorry

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 747
    • View Profile
Re: Multiplayer is LITERALLY UNPLAYABLE
« Reply #3 on: June 29, 2017, 07:52:17 pm »
Ugh, more event bugs... I'll see what I can do...

The particle related bug is probably caused because the client could not spawn the particle - See the "Could not spawn particle: 'green_smoke'" messages (it probably hit the max particles) which IIRC causes the client to get rid of the corresponding LE, but the enttity was spawned correctly on the server, thus when the server tells the client to do something with the particle the client crashes with a LE_NotFoundError

I'll need to go hunting for the other ones, unfortunately these event bugs can be quite elusive...