project-navigation
Personal tools

Author Topic: Trouble Installing on OSX  (Read 4395 times)

AlienHunter23

  • Guest
Trouble Installing on OSX
« on: December 08, 2015, 12:32:12 am »
I've been having trouble getting things to properly compile and install on OSX.
I'm running OSX 10.7.5 (Lion) and have completed the following up to this point:
I. Installed Xcode , X11/XQuartz, and MacPorts

II. Installed following dependencies:
sudo port install libsdl-framework libsdl_mixer-framework libsdl_ttf-framework \
jpeg libpng XviD libtheora gtk2 gtkglext gtksourceview2 git p7zip python27 \
doxygen libsdl2 libsdl2_mixer libsdl2_ttf

III. Cloned Git repository and compiled source:
git clone git://git.code.sf.net/p/ufoai/code ufoai
cd ufoai
./configure
make
make lang models maps-sync
make macinstaller 

*while this last command ran, I could not find a resulting dmg named "macinstaller" or "ufoai" anywhere.*

IV. Made the following change to .profile
export PATH=$PATH:/opt/local/bin:/opt/local/sbin:/opt/local


As I could not find the application to run anywhere, post compiling I attempted to download the ufoai 2.6 universal dmg from http://ufoai.ninex.info/snapshots.  However, every attempt to run the dmg simply resulted in an immediate crash of the application.
I've placed a copy of the resulting error report below.

Any assistance anyone can give would be greatly appreciated.

Error Report from DMG:
Process:         launchd [17177]
Path:            /Volumes/VOLUME/UFOAI.app/Contents/MacOS/ufo
Identifier:      net.sourceforge.UFOAI
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [114]

Date/Time:       2015-12-07 16:32:14.978 -0700
OS Version:      Mac OS X 10.7.5 (11G63)
Report Version:  9

Interval Since Last Report:          200316 sec
Crashes Since Last Report:           4
Per-App Crashes Since Last Report:   4
Anonymous UUID:                      CDE512CD-C8F2-4413-A324-05D506C21411

Crashed Thread:  Unknown

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x0000000000000000
   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000
  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000
  rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028
Logical CPU: 0

Binary images description not available


External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 24698
    thread_create: 0
    thread_set_state: 0



Offline jfoevv820ueb

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Trouble Installing on OSX
« Reply #1 on: March 06, 2016, 05:15:39 am »
Bump.

Getting the same trouble trying to compile the game.  The make macinstaller command ran fine, but after it ran I got this in the terminal:

done
cp: README: No such file or directory
make: *** [copynotes-ufoai] Error 1

Didn't have any other errors during compile, and no .dmg was created.

Hope this gets the attention it needs  :-\


Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Re: Trouble Installing on OSX
« Reply #2 on: March 06, 2016, 02:46:01 pm »
Didn't you get a working executable then ? Try to run it from the terminal respectively the source directory ?!

Offline jfoevv820ueb

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Trouble Installing on OSX
« Reply #3 on: March 06, 2016, 05:31:03 pm »
...I didn't even think about trying that.  Running the command ./ufo starts up the game just fine, and the executable works just fine now, too.  Before it was giving me an error in the terminal on launch, but now it works.  Thanks! :-P

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 746
    • View Profile
Re: Trouble Installing on OSX
« Reply #4 on: March 07, 2016, 06:13:39 am »
So the README file was removed and the makefiles weren't updated (neither was the NSIS script, but that was fixed a while ago when the buildbot complained...) I've fixed that now, but since I don't have a mac to test on I can't guarantee that was the only problem...

Offline ashtiboy

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: Trouble Installing on OSX
« Reply #5 on: March 09, 2017, 12:11:11 am »
i think you need at lest mac os X 10.8 and up to run the 2.6 build becuse any mac os x version before that will not work due to the sdl reworking  dueing between mac os x version 1-7 get a up to date os thats at lest 8 and up with xcode that comes with sead os and make sure that the game is not run in the dmg but in the apps folder instead if this helps thats how i got it to work becuse durring mac os x 1-7 apple was remodleing there framework files very fast so you need mac os x 8 and up thats when the frame works stoped being moved around and by the way the 2.6 universal build works on mac os x 10.12.1 on my late 2015 27 inch imac with renta 5k just fine with just little to no isues other then kinda some off center click and drag issues
« Last Edit: March 09, 2017, 12:16:06 am by ashtiboy »