project-navigation
Personal tools

Author Topic: Game not starting on Gentoo  (Read 3254 times)

Offline Franz

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Game not starting on Gentoo
« on: December 03, 2015, 04:12:47 pm »
Hi all, the game compiled and installed fine, but it won't run. What I get in the terminal is this:

Code: [Select]
---- endianness initialization -----
found little endian system
 
---- filesystem initialization -----
Adding game dir: /usr/share/games/ufoai/base
Added packfile /usr/share/games/ufoai/base/0base.pk3 (15 files)
Added packfile /usr/share/games/ufoai/base/0maps.pk3 (740 files)
Added packfile /usr/share/games/ufoai/base/0materials.pk3 (57 files)
Added packfile /usr/share/games/ufoai/base/0media.pk3 (11 files)
Added packfile /usr/share/games/ufoai/base/0models.pk3 (1725 files)
Added packfile /usr/share/games/ufoai/base/0music.pk3 (46 files)
Added packfile /usr/share/games/ufoai/base/0pics.pk3 (1056 files)
Added packfile /usr/share/games/ufoai/base/0shaders.pk3 (37 files)
Added packfile /usr/share/games/ufoai/base/0snd.pk3 (354 files)
Added packfile /usr/share/games/ufoai/base/0textures.pk3 (1767 files)
Added packfile /usr/share/games/ufoai/base/0ufos.pk3 (109 files)
Added packfile /usr/share/games/ufoai/base/1maps.pk3 (3 files)
Adding game dir: ./base
Adding game dir: /home/xxx/.ufoai/2.4/base
using /home/xxx/.ufoai/2.4/base for writing
executing filesystem.cfg
executing default.cfg
couldn't execute config.cfg
 
----- network initialization -------
libcurl/7.45.0 OpenSSL/1.0.2d zlib/1.2.8 initialized.
 
------ server initialization -------
added 8 maps to the mapcycle
 
----- console initialization -------
Console initialized.
 
------- video initialization -------
SDL version: 1.2.15
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1920x1200 1680x1050 1600x1200 1280x1024 1152x864 1024x768 832x624 800x600 720x400 640x480 640x350 (11)
I: video driver: x11
I: setting mode -1
I: set multisample buffers to 0
I: set swap control to 0
]Fatal error in __driConfigOptions line 1, column 0: (null).
Error: Received signal 6.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Game not starting on Gentoo
« Reply #1 on: December 04, 2015, 09:12:31 pm »
You need 3D hardware accelerated, OpenGL capable video card and driver for UFO:AI. Which video card and driver you use?

-geever

Offline Franz

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: Game not starting on Gentoo
« Reply #2 on: December 08, 2015, 03:22:02 pm »
You need 3D hardware accelerated, OpenGL capable video card and driver for UFO:AI. Which video card and driver you use?

-geever

Thanks for the reply.

I use an AMD 4870 with the latest open source drivers.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Game not starting on Gentoo
« Reply #3 on: December 08, 2015, 06:47:07 pm »
I would try the closed-source driver from AMD, maybe the OSS driver cannot yet support the card fully.

-geever

Offline gentooza

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Game not starting on Gentoo
« Reply #4 on: February 29, 2016, 12:54:39 pm »
Hi Franz

did you solve the problem?

I've the same issue with UFO-AI, gentoo and my AMD HD 8690M but I'd prefer not to install any closed driver. (I already hate to have binary blobs in Linux to have 3d working)

I want to say also this package seems to be not to well maintained in gentoo.
https://packages.gentoo.org/packages/games-strategy/ufo-ai

we are using an old version (2.4) the 2.5 version was removed due to lack of maintenance.

cheers