project-navigation
Personal tools

Author Topic: what is wrong with you develompent politics???  (Read 6452 times)

Offline tenim

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
what is wrong with you develompent politics???
« on: August 27, 2014, 10:12:55 pm »
ok, i have tried to play ufo:ai. downloaded the 2.5 "stable" (good joke !) version (win).
the font is unreadable, but this is a "stable" version?! has anyone tested this version? i mean not the linux version, the windows version?

after a little search in this forum i have found out the font-problem is probably the sdl2 version, if one compile new with sdl 1 everything should be fine (this sounds so easy!).

yo, i decided to do so!
downloaded the source code for the 2.5er "stable" version (a tar.bz2). 7zip can handle that format and i unpacked the source in an folder. then i saw a code blocks project file in the source. i was happy, i thought i can EASILY compile the project just by open the code blocks file and adjust the include paths of the header files. nope! this doesn´t work.
the project has a linux makefile, that overwrites the codeblocks settings. the makefile is unable to compile under windows with mingw and msys. some issues come together, one example is i.e. "sockets.h" which doesn´t exist under windows (->winsocks2.h) and so one. why you doesn´t support an CMAKE file!!! it runs under win and linux without problems. but then, windows users can easy handle everything, you dont want that right? if i have a code blocks project, every configuration stuff is saved in this project and one can compile the whole stuff over the code blocks project settings. but not in your case. you have a separate makefile that overwrites the code blocks settings. why you have a code blocks project if you do everything with a custom makefile?

i brassed of this shit. if you provide source code to download then please adapt this version on the destination os.
95% of the world DONT USE LINUX! realize this!

« Last Edit: August 27, 2014, 10:17:19 pm by tenim »

Offline MonkeyHead

  • Squad Leader
  • ****
  • Posts: 127
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #1 on: August 28, 2014, 12:05:50 am »
2.5 works fine out of the box for me on Win7. I suspect the problem lies at your end, rather than with the game.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #2 on: August 28, 2014, 12:50:46 am »
Instead of asking "what is wrong with you develompent politics???" you should ask "what's wrong with yourself" at the mirror...

What you wrote has nothing to do with politics...

Maybe I could understand your frustration if you asked for help and the We told you that we don't care. But it is not what happened. We do care about product quality and we do our best in that limited time we have for it.
We're a small team with full-time jobs for living pretty busy real life. And yes, some of us use Linux, and for the same reason you don't switch to Linux we don't switch to Windows.But for reassurance I tell you that the Linux buildchain is not much better, it won't compile the game for you either if you don't install the required libs..

-geever

Offline ShipIt

  • Project Artist
  • Captain
  • ***
  • Posts: 906
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #3 on: August 28, 2014, 06:51:57 am »
Well, at least it is no complaint about the terrain being indestructible.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: what is wrong with you develompent politics???
« Reply #4 on: August 28, 2014, 07:35:21 am »
what I realize is that you did not provide any patch to improve the situation. So what exactly are you thinking we can do to solve your problem? We are those 5% that don't use windows - so we can't even test it. Even the installer version is compiled from linux. As long as you don't contribute - please don't waste our time with statements like these. We are working hard in our free/unpaid time to provide a high quality and addictive game => realize THIS.

Offline AntJam

  • Rookie
  • ***
  • Posts: 91
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #5 on: August 28, 2014, 12:27:55 pm »
   Well now you have annoyed all the people who actually work on , improve and maintain the game (in their free time no less) by posting when your angry/frustrated I'd like to say I compile the game (2.6 dev) from git with the codeblocks package in Windows Vista with zero experience by closely following the instructions given and it works fine.

   Unfortunately that means all I can offer is that it is possibly to compile the game on windows with the supplied files not why you are unable to do so.

Offline tenim

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #6 on: August 28, 2014, 04:31:08 pm »
Quote
2.5 works fine out of the box for me on Win7. I suspect the problem lies at your end, rather than with the game.

definitively no. here:
http://ufoai.org/forum/index.php/topic,7943.0.html
and here:
http://ufoai.org/forum/index.php/topic,8681.0.html
are people that reported the same bug, i talked about. they where asked to post a screenshot, they posted the screenshot and then, nothing happend -in both cases. this looks for me like "i don´t care".

Quote
what I realize is that you did not provide any patch to improve the situation. So what exactly are you thinking we can do to solve your problem?
how can i provide a patch if i can´t get the source compiled? btw. the patch is to use sdl1 instead of 2, according to a user (blau):
>Maybe something to do with SDL 2. Compiling with SDL 1 makes everything look fine.
i exactly want to do that but without luck.

Quote
We are those 5% that don't use windows - so we can't even test it. Even the installer version is compiled from linux.
you provide a windows version and call it stable without testing it?
>We do care about product quality and we do our best in that limited time we have for it.
it doesn´t figure.

Quote
I'd like to say I compile the game (2.6 dev) from git with the codeblocks package in Windows Vista with zero experience by closely following the instructions given and it works fine.

as i write in my initial post. i want to compile the 2.5 stable version, not the unstable dev, and the source-version
from here
http://ufoai.org/wiki/Download
doesn´t compile under windows, and i have tried many things.

i understand, that you people work in your free time and this without fee, but i tried >8 hours in my free time to get this software compiled. 8 hours for nothing (i know you spend even more than 8 years in the project). i have successfully compiled many other linux freeware stuff, mainly why they supported cmake files or code blocks project files (only, not in combination with custom makefiles). i like the xcom series very much and was very happy to see this project after 6? years in this new style. i like your game and i´m looked forward to play it but it´s not possible with this font, i can read the text no longer than 5 minutes. this is why i´m angry. i´m angry why i can do nothing to get the font problem fixed.
this windows-gui tool to compile the source without knowledge "make_UfoAI_win32.exe" would have eventually helped my but it is no longer maintained and doesn´t work with actual sources:
http://ufoai.org/forum/index.php/topic,3843.300.html

sorry for the harsh words, but i´m not a creep.

so long, i wait for version 2.6. what i saw from the screenshots a new font is used which seems very good readable.

tenim

Offline MonkeyHead

  • Squad Leader
  • ****
  • Posts: 127
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #7 on: August 28, 2014, 06:34:20 pm »
With the text in the 2 examples you post, I really cant see what the issue is - it hardly looks unreadable, and looks very much like what I see when I play the game. If this is an aesthetics issue, it clearly is not a bug. I repeat - If the text is unreadable on your display I strongly suspect that the problem lies at your end, not with the game, based on how many users are not complaining about this and are getting by just fine. It is more than readable for me, and I simply install from the package available from the downloads page. Possibly what you have on your system is incompatible in some way with the game. I for one a few moths ago had an issue where I would get little or no text on certain screens - the solution was to check my SDL video drivers, which were out of date and not functioning properly, or so it seemed. Updating them solved that problem.
« Last Edit: August 28, 2014, 06:36:57 pm by MonkeyHead »

Offline diegobf109

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: what is wrong with you develompent politics???
« Reply #8 on: April 26, 2015, 04:30:55 am »
Beyond the point of how he made his complaint, the fact is that the issue is real.
Text in version 2.5/6 does look bad in multiple systems.
I would not be surprised if it is related to the video card and screen resolution.
I have tried changing my video resolution, but no luck.
Perhaps is a problem with NVidia cards?