project-navigation
Personal tools

Author Topic: UFO AI2.5 deb package  (Read 8631 times)

Offline cevaralien

  • Rookie
  • ***
  • Posts: 85
    • View Profile
UFO AI2.5 deb package
« on: July 28, 2014, 12:05:06 am »
I´m linux user, but i don´t understand how to compile the game. It´s possible to get it in a .deb package?

Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Re: UFO AI2.5 deb package
« Reply #1 on: July 28, 2014, 05:41:14 pm »
I find it generally easier and more stable to compile programs instead of getting them by other means in the case of Linux.
The apt system makes getting prerequisites easy. Successful compilation makes it very likely program will run without problems. Can be run just from the compilation directory, .deb forces you to install it and scatter the stuff all over the OS. Getting needed .debs and such seems to fail much less for me when I compile things. Getting up-to-date .debs is sometimes difficult or not possible (as for you just now with UFO AI).
So, it's worth learning to compile I'd say. Guides are usually up-to-date and easy to follow.

Offline Gwin

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: UFO AI2.5 deb package
« Reply #2 on: August 05, 2014, 09:34:58 am »
I've just found 2.5 Debian/Ubuntu binaries at PlayDeb.

Offline cevaralien

  • Rookie
  • ***
  • Posts: 85
    • View Profile
Re: UFO AI2.5 deb package
« Reply #3 on: August 10, 2014, 11:43:29 pm »
Ok. I followed the compilance guide but i have many questions. I'm new with Linux so, be patient  ;D

1. I downloaded these files: ufoai-2.5-source.tar.bz2 , ufoai-2.5-data.tar and ufoai-2.5-mappack.tar.bz2

2. I unpack these files.

3. I installed all the packages.  http://ufoai.org/wiki/Debian

Where i must begin to do ./configure and make? I do it in the "ufoai-2.5-source" folder and after that the make. But i don't know if it works or not. I don't know how to run the game.

Can someone gives me a more specific procedure to compile the game? Thanks

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: UFO AI2.5 deb package
« Reply #4 on: August 11, 2014, 01:02:34 am »
I write this out of mind so I might be wrong on some details, I'll try to confirm it in the next few days. But "it should work" (TM).

I think you don't need the mappack if you have the data tar as it should contain the compiled maps already. Mappack is the map sources for map makers IIRC.

The step-by-step instructuctions:
1. Create a directory for ufoai. It will be ~/ufoai in this guide.
2. Unpack ufoai-2.5-source.tar.bz2 into ~/ufoai
3. Create ~/ufoai/base directory
4. Unpack ufoai-2.5-data.tar into ~/ufoai/base
5. From ~/ufoai, run `make'. It will run `configure' first time
6. From ~/ufoai, run `make lang'. This will compile the translation files.
7. Run `ufo'


-geever

Offline cevaralien

  • Rookie
  • ***
  • Posts: 85
    • View Profile
Re: UFO AI2.5 deb package
« Reply #5 on: August 13, 2014, 04:14:32 am »
Thanks i will try it.

Offline Internecivus

  • Rookie
  • ***
  • Posts: 64
  • Sometimes I Code
    • View Profile
Re: UFO AI2.5 deb package
« Reply #6 on: August 13, 2014, 09:05:12 am »
I suggest
8. `make maps-sync' to update maps

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: UFO AI2.5 deb package
« Reply #7 on: August 13, 2014, 03:25:30 pm »
I suggest
8. `make maps-sync' to update maps

The data.tar contains the compiled maps. If he wants to play multiplayer with other people using the released 2.5 he shouldn't update the maps from the repo.

-geever

Offline hay207

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFO AI2.5 deb package
« Reply #8 on: May 03, 2015, 01:16:01 pm »
Hi, i am having some problems with compiling the game, my distro is lmde debian based..
First is there a binary deb package for v2.5
Second , i downloaded all files needed, but when i am installing the pre-requistes, libsdl requires the deletion of these attached packages, won't this cause a problem to my OS?

libsdl1.2-dev
Impact on packages:
The following packages would be installed: libgl1-mesa-dev, libxshmfence-dev, libglu1-mesa-dev, libxdamage-dev, libxxf86vm-dev, libfreetype6-dev, libdirectfb-dev, libxcb-dri3-dev, libavahi-client-dev, libdrm-dev, libxcb1-dev, libpulse-dev, libmad0-dev, libx11-xcb-dev, libxau-dev, libglib2.0-dev, x11proto-dri2-dev, x11proto-damage-dev, libasound2-dev, x11proto-core-dev, libsdl-mixer1.2-dev, libxcb-shape0-dev, libxcb-render0-dev, libdirectfb-extra, x11proto-xf86vidmode-dev, libx11-dev, x11proto-kb-dev, libslang2-dev, libxcb-randr0-dev, libjpeg62-turbo-dev, libflac-dev, libxcb-dri2-0-dev, libxdmcp-dev, x11proto-gl-dev, x11proto-fixes-dev, libsdl-ttf2.0-dev, libxcb-sync-dev, libdbus-1-dev, libpcre3-dev, libpng12-dev, libcaca-dev, libxfixes-dev, xorg-sgml-doctools, libxext-dev, x11proto-xext-dev, x11proto-input-dev, libpcrecpp0, libxcb-present-dev, libmikmod-dev, libpthread-stubs0-dev, mesa-common-dev, libmikmod-config, libxcb-glx0-dev, libjpeg-dev, libavahi-common-dev, libxcb-xfixes0-dev

The following packages would be removed: pulseaudio, libegl1-mesa-drivers, libpulse-mainloop-glib0, libx11-xcb1, libdrm-intel1, pulseaudio-module-x11, libdrm-radeon1, libfreetype6, libglib2.0-0, libglapi-mesa, libflac8, pulseaudio-utils, libgl1-mesa-glx, libxdmcp6, libavahi-client3, libsdl1.2debian, libdrm-nouveau2, libavahi-common3, pulseaudio-module-bluetooth, libxxf86vm1, libpulsedsp, libglib2.0-bin, libpulse0, libdrm2, libx11-6, libxshmfence1

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 747
    • View Profile
Re: UFO AI2.5 deb package
« Reply #9 on: May 03, 2015, 08:44:22 pm »
Hi, welcome to the forums

Yes removing those, will most likely cause problems... I see one of the packages to be removed is libsdl1.2debian I 'm assuming there isn't a libsdl1.2debian-dev package you could use instead?

Offline hay207

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFO AI2.5 deb package
« Reply #10 on: May 03, 2015, 08:51:48 pm »
no there isn't, i am present at irc now

Offline TBeholder

  • Rookie
  • ***
  • Posts: 54
    • View Profile
Re: UFO AI2.5 deb package
« Reply #11 on: May 04, 2015, 06:16:34 pm »
Hi, i am having some problems with compiling the game, my distro is lmde debian based..
First is there a binary deb package for v2.5
Second , i downloaded all files needed, but when i am installing the pre-requistes, libsdl requires the deletion of these attached packages, won't this cause a problem to my OS?
libsdl1.2-dev
Impact on packages:
Yup. It may want a different version of one package, apt tries to obey the dependencies, and then it have to remove everything that depends on the old (to-be-removed) version, and this happens. "-dev" still may clash with the main library of a "wrong" version, too.
Usually this may be fine-tuned by trying to pick the packages to upgrade.
I got right versions of everything, but installed ready ufoai (2.5-1~getdeb1), not messed with source, and run Xubuntu, so my versions of some libraries may be different from your distro. Speaking of which, check what you already have:
Code: [Select]
$ dpkg-query -l "libsdl*" | grep "^ii"
ii  libsdl-gfx1.2-4:amd64                       2.0.23-3                                   amd64        drawing and graphical effects extension for SDL
ii  libsdl-gfx1.2-dev:amd64                     2.0.23-3                                   amd64        development files for SDL_gfx
ii  libsdl-image1.2:amd64                       1.2.12-5build2                             amd64        Image loading library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-image1.2:i386                        1.2.12-5build2                             i386         Image loading library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-image1.2-dev:amd64                   1.2.12-5build2                             amd64        Image loading library for Simple DirectMedia Layer 1.2, development files
ii  libsdl-mixer1.2:amd64                       1.2.12-10                                  amd64        Mixer library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-mixer1.2-dev:amd64                   1.2.12-10                                  amd64        Mixer library for Simple DirectMedia Layer 1.2, development files
ii  libsdl-net1.2:amd64                         1.2.8-4                                    amd64        Network library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-sound1.2:amd64                       1.0.3-7                                    amd64        Sound library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-sound1.2:i386                        1.0.3-7                                    i386         Sound library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-sound1.2-dev:amd64                   1.0.3-7                                    amd64        Sound library for Simple DirectMedia Layer 1.2, development files
ii  libsdl-ttf2.0-0:amd64                       2.0.11-3                                   amd64        TrueType Font library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl-ttf2.0-0:i386                        2.0.11-3                                   i386         TrueType Font library for Simple DirectMedia Layer 1.2, libraries
ii  libsdl1.2-dev                               1.2.15-8ubuntu1.1                          amd64        Simple DirectMedia Layer development files
ii  libsdl1.2debian:amd64                       1.2.15-8ubuntu1.1                          amd64        Simple DirectMedia Layer
ii  libsdl1.2debian:i386                        1.2.15-8ubuntu1.1                          i386         Simple DirectMedia Layer
ii  libsdl2-2.0-0:amd64                         2.0.2+dfsg1-3ubuntu1.1                     amd64        Simple DirectMedia Layer
ii  libsdl2-mixer-2.0-0:amd64                   2.0.0+dfsg1-3                              amd64        Mixer library for Simple DirectMedia Layer 2, libraries
ii  libsdl2-ttf-2.0-0:amd64                     2.0.12+dfsg1-2                             amd64        TrueType Font library for Simple DirectMedia Layer 2, libraries
Generally, if plain "apt-get install ufoai" proposes to remove something, you may try to:
1) install ufoai and its explicit dependencies like this:
Code: [Select]
apt-get install --reinstall -s ufoai libsdl1.2debian:amd64/trusty libgl1-mesa-glx:amd64/trusty libsdl2-2.0-0:amd64/trusty libpng12-0:amd64/trusty
(replace "trusty" with your distribution, see in deb lines - it's the first parameter after URL in /etc/apt/sources.list; replace amd64 with your arch, if necessary)
2) repeat, adding like this at the end other libraries about which apt complains as "is required, but not to be installed" (with full "name:arc/distribution", don't let apt guess on its own beyond adding origin variations like "distro-updated" - it already failed to pick the right tree).
3) at some point, nothing but libraries will appear under "to be removed"; then re-run your last attempt without "-s".
Unless you have mix distros (I once had Ubuntu with a few drops from Debian repositories, due to slow update of certain buggy packages) it should work.

Offline hay207

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFO AI2.5 deb package
« Reply #12 on: May 04, 2015, 09:08:46 pm »
Hi, First geever was saying to run configure and make from parent directory ufoai which contains only the files downloaded from source forge, configure and make are found in the source folder after extracting it.

Secondly i didn't notice the presence of synaptic , so i installed sdl from there correctly without package removal (thanks for the explanation) apart from mintinstall.

Third, i have no ufoai prepackaged to install.

Forth, here is my log from make, http://pastebin.com/0JReLyJd

Fifth if compiling will take long, how to get the precompiled maps.

Sixth, where to run the command ufo from?

Offline hay207

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFO AI2.5 deb package
« Reply #13 on: May 05, 2015, 10:22:37 am »
ok after synaptic sdl install , make won't complete successfly, i asked drane in IRC, he said to install libcurl4-gnutls-dev  libcurl4-openssl-dev , then compile succeded, and a ufo file was created, but when i run it, the game won't start and gives me this log http://pastebin.com/q3UpSFF5 ...

Offline hay207

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFO AI2.5 deb package
« Reply #14 on: May 05, 2015, 02:14:21 pm »
Ok finally i got it worked, thanks to drane on IRC

Here is the old nonworking log http://pastebin.com/2tFy7HX6

And here is the working log http://pastebin.com/4rGenAST

what i did was moving my ufoai folder from my home folder and make it in a hidden folder with the same name, so that it is instead of ~/ufoai it becomes ~/.ufoai