project-navigation
Personal tools

Author Topic: UFO AI2.5 deb package  (Read 8627 times)

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 747
    • View Profile
Re: UFO AI2.5 deb package
« Reply #15 on: May 07, 2015, 02:02:52 am »
To be honest the instructions at the wiki are assuming that you are compiling from the git repository AFAIK we don't have instructions specific to compile from the source/data packs... I'll have to try it one of these days, I'm using openSUSE but the only thing that should vary from distro to distro is how to get the right dependencies.

Offline hay207

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFO AI2.5 deb package
« Reply #16 on: July 09, 2015, 03:47:16 am »
ok, after trying to install manually dependencies,

i saw that libsdl-dev has no version 1.2 or 2 should be installed
And the big dependency that many packages conflict with is libjpeg8-dev

i hope it get fixed .

ofc ,i want to install .deb package the smart way by doing
Code: [Select]
dpkg-buildpackage -rfakeroot -us -uc explained here: http://forums.debian.net/viewtopic.php?f=16&t=38976
« Last Edit: July 09, 2015, 03:53:38 am by hay207 »

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 747
    • View Profile
Re: UFO AI2.5 deb package
« Reply #17 on: July 09, 2015, 08:15:11 pm »
The game can be compiled with either SDL 1.2 or SDL 2, pick the one you want (or the one that is available) there was a point at which libjpeg8 was required but that has since been rectified and earlier versions should work too, but since I don't use a debian based system I can't offer much help with building a .deb unfortunately...