project-navigation
Personal tools

Author Topic: Minimizing the build prerequisites list  (Read 2472 times)

Offline anonymissimus

  • Sergeant
  • *****
  • Posts: 347
    • View Profile
Minimizing the build prerequisites list
« on: June 07, 2015, 04:48:49 pm »
I just replaced my main Linux system, ubuntu precise, by a fresh Lubuntu trusty install (no upgrade) and am getting several projects to compile again, of which UFO:AI happens to be the first one, so there is little chance for some other project/package/whatever to already have required some prerequisite for building/running UFO:AI.
remarks regarding http://ufoai.org/wiki/Debian (building master):
-git-core is now git
-I have installed nothing of (but all are available in my repo and mentioned as build requirements on the site above)
libtheora-dev libjpeg8-dev libxml2-dev libopenal-dev p7zip-full binutils-dev libxvidcore-dev libmxml-dev
but yet I get a working ./ufo binary, how can that be ?
For a good number of the prerequisites, I basically waited for make to stop the build due to a missing header and then installed the corresponding package, and I had used make clean to ensure g++ should need all those headers.
-libcurl3-dev: This package doesn't exist in my repos and IIRC it was the same in precise. ./configure complains about not finding the header but the build succeeds anyway...

I didn't attempt building the tests or radiant for now.

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 747
    • View Profile
Re: Minimizing the build prerequisites list
« Reply #1 on: June 12, 2015, 02:28:46 am »
<...>
-I have installed nothing of (but all are available in my repo and mentioned as build requirements on the site above)
libtheora-dev libjpeg8-dev libxml2-dev libopenal-dev p7zip-full binutils-dev libxvidcore-dev libmxml-dev
but yet I get a working ./ufo binary, how can that be ?
<...>

Did you have a look at src/libs? The game can and will build using those.

That said, some of those are indeed optional (like binutils-dev, or the fact that you only need one of theora or xvid IIRC)