project-navigation
Personal tools

Author Topic: font problem 2.5 latest (sept/03/13)  (Read 4422 times)

Offline RealSpirit

  • Rookie
  • ***
  • Posts: 33
    • View Profile
font problem 2.5 latest (sept/03/13)
« on: September 04, 2013, 12:18:39 am »
forgot: W7 / 64 bit | used full installer

what i had:

2.4 full
2.5 (June) installed in separate folder

what i did

installed new 2.5 on top of the June version, after having problems with resolution (lowest resolution for some reason) & font removed all, reinstalled latest version

after that i changed everything back to settings i used before, but the font problem still remains (looks like no TTF on wrong size, pixelized)

QUESTIONS

did you (devs) changed anything on behalf of fonts, or is it me, and if: how could i try to fix it?
Any ideas?

EDIT: explanation: every text smaller than the text of buttons is weird now, be it help text, text within the initial menu, numbers in any subpart of the main menu (employee, research, buy/sell, whatever)
« Last Edit: September 04, 2013, 01:18:41 am by RealSpirit »

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: font problem 2.5 latest (sept/03/13)
« Reply #1 on: September 04, 2013, 10:21:17 am »
can you please post a screenshot?

Offline RealSpirit

  • Rookie
  • ***
  • Posts: 33
    • View Profile
Re: font problem 2.5 latest (sept/03/13)
« Reply #2 on: September 04, 2013, 11:32:59 am »
hope this one works....


other things that came up:

- got no pictures of landed and crashed ufos on world map (only red cross instead)
- hospital is quite "filled" with workers, scientists, pilots and so on, all green. did that happen by intention?

Offline blau

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: font problem 2.5 latest (sept/03/13)
« Reply #3 on: September 07, 2013, 09:11:19 pm »
I have the same font rendering problem (and startup on 320x200 resolution) on OS X 10.8 with 2.5 dev code pulled from git today.

Maybe something to do with SDL 2. Compiling with SDL 1 makes everything look fine.

Offline Conan

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: font problem 2.5 latest (sept/03/13)
« Reply #4 on: January 25, 2014, 09:39:18 pm »
Hi,

I have the same font issue with latest build: 2.5-dev Dec 27 2013.
Using Win 7 Ultimate 64bit, Radeon HD 6870, catalyst version 13.12

Offline albedo

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: font problem 2.5 latest (sept/03/13)
« Reply #5 on: July 07, 2014, 10:54:12 pm »
Mhh, same thing here at Win8.1 64-bit. However, I did not have any problems with it - did not even noticed that till now.  ;)

other things that came up:

- got no pictures of landed and crashed ufos on world map (only red cross instead)
- hospital is quite "filled" with workers, scientists, pilots and so on, all green. did that happen by intention?

I guess, the pictures were just replaced by the red cross. I do not have pictures as well. In my case, all soldiers are shown in the hospital view including their current state.

Offline ShipIt

  • Project Artist
  • Captain
  • ***
  • Posts: 906
    • View Profile
Re: font problem 2.5 latest (sept/03/13)
« Reply #6 on: July 08, 2014, 06:37:53 am »
I don´t think the mission icons were removed. They just ... vanished. Somehow. Sometime.

The soldiers showing up in the hospital screen might be related to mattn´s work on the implants. Thats still wip I guess.