project-navigation
Personal tools

Author Topic: Mouse button not working  (Read 3560 times)

Offline nixcalo

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Mouse button not working
« on: October 16, 2013, 01:25:24 am »
Hello to all.

I have downloaded the Windows 2.6 full install package (latest update) in October 2013. And once installed, I execute the program and the mouse button does not work. I am stuck at the page where I choose the language and name and Volume Controls (right at the beginning!). When I hover the pointer over the buttons, they are highlighted, and the mouse moves correctly, but I am not able to press ANY button. It's as if the left click button is not working.

I have run it in Safe Mode and windowed mode to no avail. I have swapped mouse buttons in Windows and nothing new happens. I have downloaded three successive nightly builds to see if the problema is solved, and it is not (now it's 16/oct/2013 and I got the latest UFO AI:binaries for Windows.

In versión 2.5, mouse worked perfectly. I am lost. I need help as I don't know what to do, and I haven't seen anything in the forum that might help me.

The only peculiar thing might be that my keyboard/mouse is a Logitech Wireless K260 model, but that has never been an issue before, not with any UFO AI build other than 2.6 (I have played all builds since 2.3). My graphic card is standard ATI, but that should not be the issue either. As I said, it worked perfectly in 2.5 and the mouse moves correctly and quickly.. it's just the damn left-click button that unables me to press any button or select anything!

So I can´t even change the language or start the game! Frustrating!

Please help,
Nixcalo


Offline jffdougan

  • Rookie
  • ***
  • Posts: 56
    • View Profile
Re: Mouse button not working
« Reply #1 on: October 16, 2013, 03:08:37 am »
The short version: stick with 2.5, as 2.6 is undergoing some major UI redevelopment and isn't into a playable state.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Mouse button not working
« Reply #2 on: October 16, 2013, 08:51:54 am »
This might also be a SDL2 issue. Is the most recent 2.5 nightly version not affected by this problem?

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Mouse button not working
« Reply #3 on: October 16, 2013, 07:55:02 pm »
Could you please upload the keys.cfg the version 2.5 generated here?

My suspect is Bug#4866.

-geever

Offline nixcalo

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Mouse button not working
« Reply #4 on: October 17, 2013, 02:53:54 am »
Dear Geever,

It seems you are absolutely right. My keys.cfg file was exactly the one that appeared in your link to Bug#4866, so no need to upload it.. this was it..
 // generated by ufo, do not modify
 // If you want to know the keyname of a specific key - set in_debug cvar to 1 and press the key
 unbindallmenu
 unbindall
 unbindallbattle

 Thankfully, I had a good keys.cfg file from a previous 2.5 installation I had uninstalled unproperly (apparently). I overwrote the V2.6 keys.cfg file with the V2.5 keys.cfg file and now it seems to work perfectly. Buttons work again!!!

Thank you. Really. If you need a detail history of what I did, please just ask.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Mouse button not working
« Reply #5 on: October 17, 2013, 08:05:03 am »
It seems you are absolutely right. My keys.cfg file was exactly the one that appeared in your link to Bug#4866, so no need to upload it.. this was it..

 Thankfully, I had a good keys.cfg file from a previous 2.5 installation I had uninstalled unproperly (apparently). I overwrote the V2.6 keys.cfg file with the V2.5 keys.cfg file and now it seems to work perfectly. Buttons work again!!!

Thank you. Really. If you need a detail history of what I did, please just ask.

I'm happy I could help. I would however note that you were lucky with 2.5 keys.cfg as we did not change anything important in it. Sometimes keys.cfgs over versions are not 100% compatible.
The workaround for this bug is usually just removing the broken keys.cfg. The game creates a correct one on second try... We still need to figure out why this happen...

-geever

Offline assemblerhead

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Mouse button not working
« Reply #6 on: November 25, 2013, 07:00:49 pm »
@geever

I also have the same problem with the front page v2.5 download ( Win32 version ).

Thanks for posting this "fix" in the forum. Will try it today.
-----
Tried it, It worked. Thanks!
« Last Edit: November 26, 2013, 06:16:08 pm by assemblerhead »