project-navigation
Personal tools

Author Topic: Running 2.5 in Mint  (Read 2363 times)

Offline Battlescared

  • Squad Leader
  • ****
  • Posts: 107
    • View Profile
Running 2.5 in Mint
« on: July 14, 2013, 01:33:24 pm »
I'm getting a run-time error with X when I try to startup ufoai.  Here is the dump:

~/Games/ufoai25 $ ./ufo
---- endianness initialization -----
found little endian system

---- filesystem initialization -----
Adding game dir: /usr/local/games/ufo//base
Adding game dir: ./base
Adding game dir: /home/mark/.ufoai/2.5-dev/base
using /home/mark/.ufoai/2.5-dev/base for writing
executing filesystem.cfg
executing default.cfg
couldn't execute config.cfg

----- network initialization -------
libcurl/7.27.0 OpenSSL/1.0.1c zlib/1.2.7 libidn/1.25 librtmp/2.3 initialized.

------ server initialization -------
WARNING: cvar 'sv_maxsoldiersperplayer' out of range (0.000000 < 1.000000)
added 11 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.15
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1680x1050 640x360 320x240 (3)
I: video driver: x11
I: setting mode -1
I: set multisample buffers to 0
I: set swap control to 0
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  154 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x280000f
  Serial number of failed request:  36
  Current serial number in output stream:  36

Not sure what to make of it, whether it's a bug or just something in configuration.  I built the maps and everything compiled fine without error, though I had to skip uforadiant.  I don't see a log file to include, though if you need me to run something with a command switch or look somewhere, let me know.

Also, I have a nVidia Geforce 550GTX running the 310.32 nvidia driver.

I believe I'm running Mint 14.1 64 bit with KDE, on an AMD Athlon 64.  I have run 2.4 successfully before, but now I seem to be getting the same error with it as well.
« Last Edit: July 14, 2013, 02:40:23 pm by Battlescared »

Offline Battlescared

  • Squad Leader
  • ****
  • Posts: 107
    • View Profile
Re: Running 2.5 in Mint (solved)
« Reply #1 on: July 14, 2013, 03:05:07 pm »
Ok, figured it out and posting in case someone else comes across a similar problem, and they might.

Apparently, after I did a round of updates a while ago, the Mint repositories had a graphics driver update that didn't install correctly and broke my openGL settings.  A few openGL games were crashing the same way.  I downloaded the latest and reinstalled the driver using the nvidia installer and ufoai came right up.