project-navigation
Personal tools

Author Topic: Load saved game very slow  (Read 19821 times)

Offline SoftwareSimian

  • Rookie
  • ***
  • Posts: 34
    • View Profile
Re: Load saved game very slow
« Reply #30 on: March 27, 2013, 06:48:40 pm »
My laptop (which machine is the one that runs UFO: AI) is a 2.00 Gb RAM machine. That certainly might explain why my load times are longer than SS's.
But are they? What are you load times like? Despite my high-end machine I'm getting 20-40 second load times.

Offline jffdougan

  • Rookie
  • ***
  • Posts: 56
    • View Profile
Re: Load saved game very slow
« Reply #31 on: March 27, 2013, 08:50:48 pm »
I think it was about 120 sec the last time I thought to try to clock it.

Offline SoftwareSimian

  • Rookie
  • ***
  • Posts: 34
    • View Profile
Re: Load saved game very slow
« Reply #32 on: April 15, 2013, 05:02:11 pm »
Looking at ufoconsole.log I see where the delay is occurring:
The whole load process should take about one second, except for this:
Quote
2013/04/15 10:41:05 ...Running subsystem 'employee'
2013/04/15 10:41:29 ...subsystem 'employee' - loaded.
24 seconds to load "subsystem 'employee'".


Full load log for reference:
Code: [Select]
2013/04/15 10:41:04 Loading savegame xml (size 69190)
2013/04/15 10:41:04 Loading savegame
...version: 4
...game version: 2.5-dev
...xml Size: 810624, compressed? y
2013/04/15 10:41:04 Shutdown gametype 'Campaign mode'
2013/04/15 10:41:04 Change gametype to 'Campaign mode'
2013/04/15 10:41:04
--- save subsystem initialization --
2013/04/15 10:41:04 added campaign subsystem
2013/04/15 10:41:04 added research subsystem
2013/04/15 10:41:04 added base subsystem
2013/04/15 10:41:04 added hospital subsystem
2013/04/15 10:41:04 added market subsystem
2013/04/15 10:41:04 added employee subsystem
2013/04/15 10:41:04 added aliencont subsystem
2013/04/15 10:41:04 added aircraft subsystem
2013/04/15 10:41:04 added alien base subsystem
2013/04/15 10:41:04 added interest subsystem
2013/04/15 10:41:04 added installation subsystem
2013/04/15 10:41:04 added mission subsystem
2013/04/15 10:41:04 added ufostores subsystem
2013/04/15 10:41:04 added production subsystem
2013/04/15 10:41:04 added messagesystem subsystem
2013/04/15 10:41:04 added stats subsystem
2013/04/15 10:41:04 added nations subsystem
2013/04/15 10:41:04 added transfer subsystem
2013/04/15 10:41:04 added xvirate subsystem
2013/04/15 10:41:04 added messageoptions subsystem
2013/04/15 10:41:04 added triggerevents subsystem
2013/04/15 10:41:04 Campaign data loaded - size 663400 bytes
2013/04/15 10:41:04 ...techs: 217
2013/04/15 10:41:04 ...buildings: 16
2013/04/15 10:41:04 ...ranks: 16
2013/04/15 10:41:04 ...nations: 8
2013/04/15 10:41:04 ...cities: 456
2013/04/15 10:41:04
2013/04/15 10:41:04 Load 'slot3' 21 subsystems
2013/04/15 10:41:04 ...Running subsystem 'campaign'
2013/04/15 10:41:05 ...subsystem 'campaign' - loaded.
2013/04/15 10:41:05 ...Running subsystem 'research'
2013/04/15 10:41:05 ...subsystem 'research' - loaded.
2013/04/15 10:41:05 ...Running subsystem 'base'
2013/04/15 10:41:05 ...subsystem 'base' - loaded.
2013/04/15 10:41:05 ...Running subsystem 'hospital'
2013/04/15 10:41:05 ...subsystem 'hospital' - loaded.
2013/04/15 10:41:05 ...Running subsystem 'market'
2013/04/15 10:41:05 ...subsystem 'market' - loaded.
2013/04/15 10:41:05 ...Running subsystem 'employee'
2013/04/15 10:41:29 ...subsystem 'employee' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'aliencont'
2013/04/15 10:41:29 ...subsystem 'aliencont' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'aircraft'
2013/04/15 10:41:29 ...subsystem 'aircraft' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'alien base'
2013/04/15 10:41:29 ...subsystem 'alien base' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'interest'
2013/04/15 10:41:29 ...subsystem 'interest' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'installation'
2013/04/15 10:41:29 ...subsystem 'installation' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'mission'
2013/04/15 10:41:29 ...subsystem 'mission' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'ufostores'
2013/04/15 10:41:29 ...subsystem 'ufostores' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'production'
2013/04/15 10:41:29 ...subsystem 'production' - loaded.
2013/04/15 10:41:29 ...Running subsystem 'messagesystem'
2013/04/15 10:41:30 ...subsystem 'messagesystem' - loaded.
2013/04/15 10:41:30 ...Running subsystem 'stats'
2013/04/15 10:41:30 ...subsystem 'stats' - loaded.
2013/04/15 10:41:30 ...Running subsystem 'nations'
2013/04/15 10:41:30 ...subsystem 'nations' - loaded.
2013/04/15 10:41:30 ...Running subsystem 'transfer'
2013/04/15 10:41:30 ...subsystem 'transfer' - loaded.
2013/04/15 10:41:30 ...Running subsystem 'xvirate'
2013/04/15 10:41:30 ...subsystem 'xvirate' - loaded.
2013/04/15 10:41:30 ...Running subsystem 'messageoptions'
2013/04/15 10:41:30 ...subsystem 'messageoptions' - loaded.
2013/04/15 10:41:30 ...Running subsystem 'triggerevents'
2013/04/15 10:41:30 ...subsystem 'triggerevents' - loaded.
2013/04/15 10:41:30 File 'slot3' successfully loaded from compressed xml savegame.

Offline Kemlo

  • Rookie
  • ***
  • Posts: 66
    • View Profile
Re: Load saved game very slow
« Reply #33 on: April 15, 2013, 07:06:20 pm »
Looking at ufoconsole.log I see where the delay is occurring:
The whole load process should take about one second, except for this:24 seconds to load "subsystem 'employee'".
I have the same issue, only this has been the case for as long as I can remember so I just assumed it was normal. Checking my log shows that the employee subsystem takes 23 second to load.
I compiled 2.5dev myself on 25/3/2013.  Running Win7 64bit, Phenom II X3 720, 8GB RAM, AMD 7850 graphics card.

Offline Conan

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: Load saved game very slow
« Reply #34 on: May 17, 2013, 10:00:20 am »
Hi, I also have the same issue with 15.May full install version, load time is 35s. I also had slow air combat in stable 2.4 version, but never slow load time before (started to play AI from stable 2.1).

Anticipation was too great to wait for a stable 2.5 :)


Win 7 64bit, RAM 4GB, VGA 1GB, CPU Q6600

Offline jcjordan

  • Squad Leader
  • ****
  • Posts: 138
    • View Profile
Re: Load saved game very slow
« Reply #35 on: May 17, 2013, 11:37:49 pm »
I've seen the same thing in my very late game version & it's at the point that SoftwareSimian mentions - in mine it's about a 2-4+min wait on the  employees. I assume it's the loading of all the employee info in the hire pools. I've got alot of unused soldiers, workmen & scientists that I'll never use. Would just having a pool that says you've got X  number of this type & not give them names/stats until actually hired work to alleviate the problem or maybe a way to dismiss/cull people from the pool?

Offline Conan

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: Load saved game very slow
« Reply #36 on: May 21, 2013, 05:16:52 pm »
Now I am in the later game and load time has increased to 45s.

Offline DarkRain

  • Project Coder
  • Captain
  • ***
  • Posts: 746
    • View Profile
Re: Load saved game very slow
« Reply #37 on: May 21, 2013, 09:01:11 pm »
@jcjordan: Can't right-click the checkbox to remove characters from the employee pools? I don't know if it will help, but trying shouldn't hurt.

Offline jcjordan

  • Squad Leader
  • ****
  • Posts: 138
    • View Profile
Re: Load saved game very slow
« Reply #38 on: May 21, 2013, 11:26:49 pm »
@jcjordan: Can't right-click the checkbox to remove characters from the employee pools? I don't know if it will help, but trying shouldn't hurt.

I didn't know about that, I'll give that a try to see what it does.

Offline SoftwareSimian

  • Rookie
  • ***
  • Posts: 34
    • View Profile
Re: Load saved game very slow
« Reply #39 on: May 22, 2013, 01:58:24 am »
Can't right-click the checkbox to remove characters from the employee pools? I don't know if it will help, but trying shouldn't hurt.
It does affect load time.

I took my worst-case end-game savefile and purged all the not-hired employees (I lost count, but there were several hundred of them, maybe 300-500 or so?, including soldiers, pilots, workers, scientists). I left the 151 active/hired employees as-is.

Before, load time with all employees (both active and inactive):
Code: [Select]
2013/05/21 19:30:45 ...Running subsystem 'employee'
2013/05/21 19:31:21 ...subsystem 'employee' - loaded.
= 36 seconds to load "employee" subsystem

After with inactive employees deleted:
Code: [Select]
2013/05/21 19:50:47 ...Running subsystem 'employee'
2013/05/21 19:50:55 ...subsystem 'employee' - loaded.
= 8 seconds to load "employee" subsystem
The "hurt", of course, is that I no longer have those employee candidates in the pool to choose from if I want to hire more employees.

Load time seems directly related to number of employees: I eliminated about 75% of my labour pool and reduced load time by about the same amount.
« Last Edit: May 22, 2013, 02:00:50 am by SoftwareSimian »

Offline Conan

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: Load saved game very slow
« Reply #40 on: June 16, 2013, 10:26:14 am »
OK, finished the 2.5-dev (jun-7-2013) and at the end load times were around 2min, hope you can fix it in stable release.

Offline Spacey

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Load saved game very slow
« Reply #41 on: July 23, 2014, 09:01:13 pm »
I have this exact problem with 2.5  =(

Offline Garibaldi

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Load saved game very slow
« Reply #42 on: August 29, 2014, 09:29:47 pm »
i'm playing on Win, v2.5. My laptop is *seriously* old, but the game ran fine for the first 'game year'. By now, halfway through the next, it is taking over 5mins to load - i can tell, because my screen-saver kicks in at around the same time.

OK, having read the above thread, it seems that deleting some of the un-hired potential staff can speed things up considerably - i have pages of pilots, for instance. I'll never need 50+ pilots!

whilst i miss the legibility of Ubuntu, i have graphics-card issues with the linux drivers (its an excuse, but its also true. Winblows bleh! But its better than nothing). My question is this - how can i remove those extra persons from the hiring list, on the Windows version? What file do i look for - or is it in-game, and i'm just being dumb??

Offline Internecivus

  • Rookie
  • ***
  • Posts: 64
  • Sometimes I Code
    • View Profile
Re: Load saved game very slow
« Reply #43 on: August 30, 2014, 01:17:51 am »

My question is this - how can i remove those extra persons from the hiring list, on the Windows version? What file do i look for - or is it in-game, and i'm just being dumb??


Click your right mouse button on hire checkbox. It will delete them.

Offline Garibaldi

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Load saved game very slow
« Reply #44 on: August 30, 2014, 04:30:06 pm »
TY!

i'd tried that on the name. :/

>>dumb<< 8)